3 DESCRIPTION
= "CORBA ORB"
4 SECTION
= "x11/gnome/libs"
5 SRC_URI
= "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.10/ORBit2-${PV}.tar.bz2 \
6 file://configure-lossage.patch \
9 DEPENDS
= "libidl popt orbit2-native gtk-doc"
11 FILES_$
{PN
} += "${libdir}/orbit-2.0/*.so"
13 S
= "${WORKDIR}/ORBit2-${PV}"
15 inherit autotools pkgconfig
17 EXTRA_OECONF
= "--disable-gtk-doc"
18 EXTRA_OEMAKE
= "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
20 do_configure_prepend
() {
22 install $
{WORKDIR
}/gtk
-doc.m4 .
/m4
/
23 install $
{WORKDIR
}/gtk
-doc.make .
/
26 do_compile_append
() {
27 sed 's
:^orbit_idl
=.
*/:orbit_idl
=$
{STAGING_BINDIR_NATIVE
}/:'
< ORBit
-2.0.pc
> ORBit
-2.0.pc.
new
28 mv ORBit
-2.0.pc.
new ORBit
-2.0.pc
32 oe_libinstall
-so
-C src
/orb libORBit
-2 $
{STAGING_LIBDIR
}
33 oe_libinstall
-so
-C src
/services
/name libORBitCosNaming
-2 $
{STAGING_LIBDIR
}
34 oe_libinstall
-so
-C src
/services
/imodule libORBit
-imodule
-2 $
{STAGING_LIBDIR
}
35 install
-m
0644 src
/services
/name
/libname
-server
-2.a $
{STAGING_LIBDIR
}/
37 for dir in orbit orbit
/poa orbit
/orb
-core orbit
/util orbit
/dynamic
; do
38 install
-d $
{STAGING_INCDIR
}/orbit
-2.0/$dir
39 ( cd
include/$dir
; for i in *.h; do install -m 0644 $i ${STAGING_INCDIR}/orbit-2.0/$dir/$i; done )
42 install
-d $
{STAGING_INCDIR
}/orbit
-2.0/ORBitservices
43 install
-m
0644 src
/services
/name
/CosNaming.h $
{STAGING_INCDIR
}/orbit
-2.0/ORBitservices
/
44 install
-m
0644 src
/services
/name
/CosNaming_impl.h $
{STAGING_INCDIR
}/orbit
-2.0/ORBitservices
/
45 install
-m
0644 src
/services
/imodule
/orbit
-imodule.h $
{STAGING_INCDIR
}/orbit
-2.0/ORBitservices
/
48 SRC_URI
[md5sum
] = "c862e3261b52a84321e89f57e5600da6"
49 SRC_URI
[sha256sum
] = "d43ff15c23f5391850f85a7d40e4bd26f82fe2c86669664fe56eff91f14c1594"