libattr: remove libattr because it is clashing with udev/attr and is not used by...
[openembedded.git] / recipes / gammu / gammu_1.26.1.bb
blobc884c02b93545e93a5b902c9e4dcfc1519c67928
1 DESCRIPTION = "GNU All Mobile Managment Utilities"
2 SECTION = "console/network"
3 DEPENDS = "bluez-libs cmake-native python mysql"
4 RDEPENDS_python-${PN} = "python-core"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://www.gammu.org/"
7 PR = "r0"
9 SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2"
11 inherit distutils-common-base cmake
13 do_configure() {
14 cd ${S}
15 sed -i 's@^cmake [^$]*\$@cmake -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_TARGET} $@' configure
16 sed -i 's@\${PYTHON_SITEDIR}@${PYTHON_SITEPACKAGES_DIR}@g' python/gammu/CMakeLists.txt
17 ./configure --prefix=${prefix} --enable-shared --enable-backup
20 do_stage() {
21 autotools_stage_all
24 # gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
25 # Replace it by custom do_stage_append():
26 #do_stage_append () {
27 # install -d ${PKG_CONFIG_DIR}
28 # cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
31 PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
33 FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu"
34 FILES_${PN}-smsd = "${bindir}/gammu-smsd*"
35 FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
36 FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${PYTHON_SITEPACKAGES_DIR}/gammu/.debug"
37 FILES_libgammu = "${libdir}/libGammu.so.*"
38 FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
39 FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??"
41 SRC_URI[md5sum] = "ba8caab6b21a2ce0fa668f9403b8319a"
42 SRC_URI[sha256sum] = "668eb037af6aa81cc104067dcb8e1cf44000b82a58638cfd485297eec76fda8d"