task-bootstrap-uionroot: add RPROVIDES
[openembedded.git] / classes / gettext.bbclass
blob3785f5acd3f28f7772b035f33db1a7c00dc55553
1 python () {
2         # Remove the NLS bits if USE_NLS is no.
3         if bb.data.getVar('USE_NLS', d, 1) == 'no':
4                 cfg = oe_filter_out('^--(dis|en)able-nls$', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
5                 cfg += " --disable-nls"
6                 depends = bb.data.getVar('DEPENDS', d, 1) or ""
7                 bb.data.setVar('DEPENDS', oe_filter_out('^(virtual/libiconv|virtual/libintl)$', depends, d), d)
8                 bb.data.setVar('EXTRA_OECONF', cfg, d)
11 DEPENDS =+ "gettext-native"
12 EXTRA_OECONF += "--enable-nls"