linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / openezx-kernel_git.bb
blob03467d078820825af60209254321d7064bd6a4fc
1 DESCRIPTION = "OpenEZX 2.6 Linux Development Kernel for the Motorola EZX GSM phones"
2 AUTHOR = "The OpenEZX Team <openezx-devel@lists.openezx.org>"
3 HOMEPAGE = "http://www.openezx.org"
4 SRCREV = "886b7c127040fe32b6780b11737af5ee83daf9b3"
5 KV = "2.6.38-oe"
6 PV = "${KV}+gitr${SRCREV}"
7 PR = "r0"
9 require linux.inc
11 # Make sure not to use thumb[-interworking]
12 ARM_INSTRUCTION_SET = "arm"
13 THUMB_INTERWORKING = "no"
15 SRC_URI = "\
16 git://git.openezx.org/openezx.git;protocol=git;branch=ezx/current \
18 S = "${WORKDIR}/git"
20 ##############################################################
21 # The kernel image used to reside on a seperate flash partition
22 # It can be flashed from userspace, so we should package it anyways
23 # (flash_unlock /dev/mtdX && flash_eraseall /dev/mtdX && flashcp /boot/zImage /dev/mtdX)
25 COMPATIBLE_HOST = "arm.*-linux"
26 COMPATIBLE_MACHINE = '(a780|e680|a910|a1200|rokre2|rokre6)'
28 # Provide a fallback kernel command line, even if parameters should be given
29 # via boot_usb or gen-blob
30 CMDLINE = "console=tty1 root=/dev/mmcblk0p2 rootfstype=ext2 rootdelay=3 ip=192.168.0.202:192.168.0.200:192.168.0.200:255.255.255.0"
31 ARM_KEEP_OABI = "1"
33 ###############################################################
34 # module configs specific to this kernel
36 #module_autoload_pxaficp_ir = "pxaficp_ir"
37 #module_autoload_snd-pcm-oss = "snd-pcm-oss"
39 do_configure_prepend() {
40 install -m 0644 ${S}/arch/arm/configs/ezx_defconfig ${WORKDIR}/defconfig
43 # linux.inc overrides LOCAVERSION but we like to have one
44 do_compile_prepend() {
45 sed -i -e '/CONFIG_LOCALVERSION=/d' ${S}/.config
46 echo 'CONFIG_LOCALVERSION="-oe"' >>${S}/.config