linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / logicpd-pxa270_2.6.17-rc5.bb
blob19fea4229a39fa85c39a4dd0ac9ab301d429f9ff
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for the LogicPD Zoom(PXA270 ref design)"
3 LICENSE = "GPLv2"
4 PR = "r3"
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/v2.6.17/linux-2.6.17-rc5.tar.bz2 \
7 file://linux-2.6.17-rc5.patch;striplevel=0 \
8 file://ucb1400-ac97-audio.patch \
9 file://ucb1400-touchscreen.patch \
10 file://defconfig"
12 S = "${WORKDIR}/linux-2.6.17-rc5"
14 COMPATIBLE_HOST = 'arm.*-linux'
16 inherit kernel
17 inherit package
19 ARCH = "arm"
21 FILES_kernel-image = ""
23 do_configure_prepend() {
24 # install -m 0644 ${S}/arch/arm/configs/lpd270_defconfig ${S}/.config
25 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
29 COMPATIBLE_MACHINE = "logicpd-pxa270"
31 SRC_URI[md5sum] = "ab96dd67e9d459d8b09aa300319a1107"
32 SRC_URI[sha256sum] = "10c17d1d77b5b2496c4da8b42f3ea3d738c766e634e5e46f0f5070bcba0876f2"