linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux_2.6.29.bb
blob924482743b1dbaa683b667567b838f09b6e20fa0
1 require linux.inc
3 PR = "r11"
5 S = "${WORKDIR}/linux-2.6.29"
7 # Mark archs/machines that this kernel supports
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_boc01 = "1"
10 DEFAULT_PREFERENCE_canyonlands = "1"
11 DEFAULT_PREFERENCE_vortex86sx = "1"
12 DEFAULT_PREFERENCE_atngw100 = "1"
13 DEFAULT_PREFERENCE_micro2440 = "1"
14 DEFAULT_PREFERENCE_ep93xx = "1"
15 DEFAULT_PREFERENCE_cm-x270 = "1"
16 DEFAULT_PREFERENCE_at2440evb = "1"
17 DEFAULT_PREFERENCE_tqm8540 = "1"
18 DEFAULT_PREFERENCE_stamp9g20evb = "1"
20 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.29.tar.bz2;name=kernel \
21 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.6.bz2;apply=yes;name=stablepatch \
22 file://defconfig"
24 SRC_URI_append_boc01 = "\
25 file://boc01.dts \
26 file://boc01.dts.v1 \
27 file://004-081205-usb.patch \
28 file://005-091008-isl12024.patch \
29 file://007-091005-lm73.patch \
30 file://008-091005-spi.patch \
31 file://011-090115-gpio.patch \
32 file://012-091019-capsense.patch \
33 file://013-091015-lcd.patch \
36 SRC_URI_append_canyonlands = " \
37 file://0001-powerpc-4xx-Add-PPC4xx-PCIe-MSI-support.patch \
40 SRC_URI_append_micro2440 = " \
41 file://0001-S3C-Backported-the-s3c2410-touchscreen-from-openmok.patch \
42 file://0002-S3C-Backported-openmoko-s-touchscreen-filters.patch \
43 file://0003-VENDOR-armworks-logo.patch \
44 file://0004-920T-Use-specific-920t-mtune.patch \
45 file://0006-S3C-Allow-the-machine-code-to-get-the-BBT-table-fro.patch \
46 file://0007-MINI2440-Add-machine-support.patch \
47 file://0008-MINI2440-Delays-command-check-response-on-SD.patch \
48 file://0009-MINI2440-Rename-the-SoC-tty-names.patch \
49 file://0010-MINI2440-creates-a-mini2440_defconfig-file.patch \
50 file://0011-MINI2440-Add-touchscreen-support.patch \
53 SRC_URI_append_ep93xx = " \
54 file://add-edb9301.patch \
55 file://edb9301-fix-machine-id.patch \
58 SRC_URI_append_cm-x270 = "\
59 file://0001-xm_x2xx-config-fix-up-CMDLINE.patch \
60 file://0002-cm-x270-nand-change-name-of-device.patch \
61 file://0003-cm-x2xx.c-add-support-for-sharp-VGA-display-panel.patch \
64 SRC_URI_append_stamp9g20evb = " \
65 file://stamp9g20.patch \
68 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=8 bpp=16 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),0x230000(root),-(config);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd4 rootfstype=jffs2"
70 do_devicetree_image_append_boc01() {
71 dtc -I dts -O dtb ${KERNEL_DEVICETREE_FLAGS} -o devicetree.v1 ${KERNEL_DEVICETREE}.v1
72 install -m 0644 devicetree.v1 ${D}/boot/devicetree-${KERNEL_VERSION}.v1
75 pkg_postinst_kernel-devicetree_append_boc01 () {
76 cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/devicetree.v1 devicetree.v1 devicetree-${KERNEL_VERSION}.v1 ${KERNEL_PRIORITY} || true
79 pkg_postrm_kernel-devicetree_append_boc01 () {
80 cd /${KERNEL_IMAGEDEST}; update-alternatives --remove devicetree.v1 devicetree-${KERNEL_VERSION}.v1 || true
84 SRC_URI[kernel.md5sum] = "64921b5ff5cdadbccfcd3820f03be7d8"
85 SRC_URI[kernel.sha256sum] = "58a5ea16d499fe06f90fcbf1d687d1235d2cb9bc28bf979867bd3faadf38fc3f"
86 SRC_URI[stablepatch.md5sum] = "0317760b52c9ac7a11de997da19a366e"
87 SRC_URI[stablepatch.sha256sum] = "0294d475cbbc6cf43db25e64b92616309086cad6be4ee463f7f4b1d16d285c27"