linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux_2.6.24.bb
blob5cc686a4c719fb20d629bb3f25242cc2b49d231a
1 require linux.inc
3 # Mark archs/machines that this kernel supports
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_gesbc-9302 = "1"
6 DEFAULT_PREFERENCE_mpc8313e-rdb = "1"
7 DEFAULT_PREFERENCE_simpad = "1"
8 DEFAULT_PREFERENCE_atngw100 = "1"
9 DEFAULT_PREFERENCE_at32stk1000 = "1"
10 DEFAULT_PREFERENCE_hipox = "1"
11 DEFAULT_PREFERENCE_cs-e9302 = "1"
12 DEFAULT_PREFERENCE_smartq5 = "1"
14 PR = "r37"
16 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=kernel \
17 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.7.bz2;apply=yes;name=stablepatch \
18 file://squashfs-lzma-2.6.24.patch \
19 file://ubifs-v2.6.24.patch \
20 file://ubifs-v2.6.24-silent-get-sb.patch \
21 file://cfi-amic.patch \
22 file://make-3.82.patch \
23 file://defconfig"
25 # Moved away temporarely until committed properly (work in progress).
26 # file://powerpc-clockres.patch \
27 # file://leds-cpu-activity.patch \
28 # file://leds-cpu-activity-powerpc.patch \
30 SRC_URI_append_simpad = "\
31 file://linux-2.6.24-SIMpad-GPIO-MMC-mod.patch \
32 file://linux-2.6.24-SIMpad-battery-old-way-but-also-with-sysfs.patch \
33 file://linux-2.6.24-SIMpad-cs3-simpad.patch \
34 file://linux-2.6.24-SIMpad-mq200.patch \
35 file://linux-2.6.24-SIMpad-pcmcia.patch \
36 file://linux-2.6.24-SIMpad-serial-gpio_keys-and-cs3-ro.patch.v2;apply=yes \
37 file://linux-2.6.24-SIMpad-ucb1x00-switches.patch \
38 file://linux-2.6.24-SIMpad-ucb1x00-ts-supend-and-accuracy.patch \
39 file://linux-2.6.24-SIMpad-hostap_cs-shared-irq.patch \
40 file://linux-2.6.24-SIMpad-orinoco_cs-shared-irq.patch \
41 file://linux-2.6.24-SIMpad-rtc-sa1100.patch \
42 file://linux-2.6.24-SIMpad-ucb1x00-audio.patch \
43 file://connectplus-remove-ide-HACK.patch \
44 file://collie-kexec.patch \
45 file://export_atags-r2.patch \
48 SRC_URI_append_gesbc-9302 = " \
49 file://0001-gesbc-nand.patch \
50 file://0002-gesbc-eth-platform.patch \
51 file://0005-ep93xx-reboot.patch \
54 SRC_URI_append_mpc8313e-rdb = "\
55 file://mpc831x-nand.patch \
56 file://mpc8313e-rdb-leds.patch \
57 file://mpc8313e-rdb-rtc.patch \
58 file://mpc8313e-rdb-cardbus.patch \
61 CMDLINE_gesbc-9302 = "console=ttyAM0 root=mtd5 rootfstype=jffs2 mtdparts=GESBC-NAND:64m(app),-(data)"
63 SRC_URI_append_cm-x270 = " \
64 file://0001-cm-x270-match-type.patch \
65 file://0002-ramdisk_load.patch \
66 file://0003-mmcsd_large_cards-r0.patch \
67 file://0004-cm-x270-nand-simplify-name.patch \
68 file://0005-add-display-set-default-16bpp.patch \
71 SRC_URI_avr32 = "http://avr32linux.org/twiki/pub/Main/LinuxPatches/linux-2.6.24.3.atmel.3.tar.bz2;name=atmelpatch \
72 file://defconfig"
73 S_avr32 = "${WORKDIR}/linux-2.6.24.3.atmel.3"
75 SRC_URI_append_ts72xx = "\
76 file://ep93xx-gpio-interrupt-debounce.diff \
77 file://ep93xx-i2c-bus.diff \
78 file://ep93xx-i2c.diff \
79 file://ep93xx-leds.diff \
80 file://ep93xx-serial-uartbaud.diff \
81 file://ep93xx-serial-clocks.diff \
82 file://ep93xx-timer-accuracy.diff \
83 file://ep93xx-maverick-uniqid.patch \
84 file://ep93xx-eth-phylib-framework.patch \
85 file://ts72xx-nfbit-fix.patch \
86 file://ts72xx-machine-id-fix.patch \
87 file://ts72xx-watchdog.patch \
88 file://ts72xx-use-cpld-reset.patch \
89 file://ts72xx-rs485.patch"
91 SRC_URI_append_hipox = " \
92 file://hipox-mach-type.patch \
93 file://hipox.patch \
94 file://hipox-uart.patch \
95 file://hipox-pci-config-delay.patch \
96 file://hipox-pci-max-size.patch \
97 file://hipox-nand.patch \
98 file://hipox-ubifs.patch \
99 file://hipox-kconfig.patch \
100 file://hipox-sata-module.patch \
101 file://hipox-OXE-INT2.patch \
102 file://hipox-rtc.patch \
103 file://hipox-nand-vs-pci.patch \
104 file://hipox-nand-vs-nor.patch \
105 file://ox810-gmac-without-leon.patch \
106 file://hipox-poe-enable.patch \
107 file://siocoutqsnd.patch \
108 file://hipox-phy.patch \
111 EXTRA_OEMAKE_smartq5 = " OBJCOPY=${OBJCOPY}"
112 SRC_URI_smartq5 = " ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2;name=kernel \
113 http://ftp.kernel.org/pub/linux/kernel/v2.6/patch-2.6.24.7.bz2;apply=yes;name=stablepatch \
114 file://smartq-gitupdate.diff \
115 file://base/0001-Apply-samsung-kernel-patch.patch \
116 file://base/0002-Apply-smartq-patch.patch \
117 file://mer/0001-Mer-keymappings-change.patch \
118 file://mer/0002-no-DM9000.patch \
119 file://mer/0003-Mer-WPA-fix.patch \
120 file://mer/0004-Mer-hardwire-USB-OTG-gadget-type.patch \
121 file://mer/0005-backlight-parameter-and-fixes.patch \
122 file://mer/0006-tv-encoder.patch \
123 file://mer/0007-make-tv-encoder-scaler-compile.patch \
124 file://mer/0008-build-TV-by-default.patch \
125 file://mer/0009-Apply-cpufreq-patch-from-gqwang.patch \
126 file://mer/0010-Better-compatibility-with-some-memory-chips.patch \
127 file://mer/0011-Only-reserve-memory-for-TV-if-CONFIG_VIDEO_SAMSUNG_T.patch \
128 file://mer/0012-Disable-TV-out-to-save-RAM.patch \
129 file://defconfig \
133 CMDLINE_cm-x270 = "console=${CMX270_CONSOLE_SERIAL_PORT},38400 monitor=1 mem=64M mtdparts=physmap-flash.0:256k(boot)ro,0x180000(kernel),-(root);cm-x270-nand:64m(app),-(data) rdinit=/sbin/init root=mtd3 rootfstype=jffs2"
135 FILES_kernel-image_gesbc-9302 = ""
137 python do_compulab_image() {
138 import os
139 import os.path
140 import struct
142 machine = bb.data.getVar('MACHINE', d, 1)
143 if machine == "cm-x270":
144 deploy_dir = bb.data.getVar('DEPLOY_DIR_IMAGE', d, 1)
145 kernel_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.bin')
146 img_file = os.path.join(deploy_dir, bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270')
148 fo = open(img_file, 'wb')
150 image_data = open(kernel_file, 'rb').read()
152 # first write size into first 4 bytes
153 size_s = struct.pack('i', len(image_data))
155 # truncate size if we are running on a 64-bit host
156 size_s = size_s[:4]
158 fo.write(size_s)
159 fo.write(image_data)
160 fo.close()
162 os.chdir(deploy_dir)
163 link_file = bb.data.expand('${KERNEL_IMAGE_SYMLINK_NAME}', d) + '.cmx270'
164 img_file = bb.data.expand('${KERNEL_IMAGE_BASE_NAME}', d) + '.cmx270'
165 try:
166 os.unlink(link_file)
167 except:
168 pass
169 os.symlink(img_file, link_file)
173 addtask compulab_image after do_deploy before do_build
176 SRC_URI[kernel.md5sum] = "3f23ad4b69d0a552042d1ed0f4399857"
177 SRC_URI[kernel.sha256sum] = "413c64fbbcf81244cb5571be4963644a1e81166a2b0f008a016528363b65c5d3"
178 SRC_URI[stablepatch.md5sum] = "0c1c5d6d8cd82e18d62406d2f34d1d38"
179 SRC_URI[stablepatch.sha256sum] = "b6bbb0dea427aa733c37d58a94b819b523c8649d7605f498348de159380c28a1"
181 SRC_URI[atmelpatch.md5sum] = "952715cc523f4a77e7c5f94f608594c0"
182 SRC_URI[atmelpatch.sha256sum] = "d26a1de101692958fbca1d1be40fe52bd605636baea616a3e8ed96e422a3648d"