linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-smdk2443_2.6.20+git.bb
blobda65c3702e52bbde8ea980a7f17841d109598e1e
1 DESCRIPTION = "Linux Kernel for smdk2443 compatible machines"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 DEPENDS += "u-boot-mkimage-native"
6 PR = "r1"
8 GGSRC = "http://www.xora.org.uk/oe/patches/"
10 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=v2.6.21-rc5 \
11 file://0020-Add-ASoC-S3C24xx-platform-support.patch \
12 file://0021-Add-Neo1973-ASoC-support.patch \
13 file://0022-Add-initial-ASoC-SMDK2440-support.patch \
14 file://0023-Add-ASoC-SMDK2440-support-for-WM8956-codec.patch \
15 file://0034-Export-ac97_dai.patch \
16 file://0036-Move-s3c24xx_i2s_dai-and-add-dma_size.patch \
17 file://0037-Use-dma_size-parameter-and-fix-buffdone-oops.patch \
18 file://0038-Add-smdk2443-s3c2443-ac97-and-wm9710-support.patch \
19 file://asoc-mainline.patch \
20 file://defconfig-smdk2443"
22 S = "${WORKDIR}/git"
24 inherit kernel
26 COMPATIBLE_HOST = "arm.*-linux"
27 COMPATIBLE_MACHINE = "smdk2443"
29 do_configure() {
30 install ${WORKDIR}/defconfig-smdk2443 ${S}/.config
31 oe_runmake oldconfig
34 do_deploy_append() {
35 ${OBJCOPY} -O binary -R .note -R .comment -S vmlinux linux.bin
36 rm -f linux.bin.gz
37 gzip -9 linux.bin
38 uboot-mkimage -A arm -O linux -T kernel -C gzip -a 30008000 -e 30008000 -n "smdk2443 kernel" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${MACHINE}-${DATETIME}.bin
39 rm -f linux.bin.gz
42 KERNEL_RELEASE = "2.6.21-rc5"