linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-ks8695_2.6.16.bb
blob1f31f2eefc63c84c4e3918cf01b29e1813e545b3
1 DESCRIPTION = "Linux kernel for Micrel KS8695(P) based devices"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r0"
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
7 file://ks8695-headers-r0.patch \
8 file://ks8695-base-r0.patch \
9 file://defconfig-ks8695"
11 S = "${WORKDIR}/linux-${PV}"
13 COMPATIBLE_HOST = 'arm.*-linux'
14 COMPATIBLE_MACHINE = "ks8695"
16 inherit kernel
17 inherit package
19 ARCH = "arm"
20 CMDLINE = "ttyS0,115200n8 root=/dev/mtdblock2 init=/linuxrc"
22 do_configure_prepend() {
23 install -m 0644 ${WORKDIR}/defconfig-${MACHINE} ${S}/.config
24 echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
27 SRC_URI[md5sum] = "9a91b2719949ff0856b40bc467fd47be"
28 SRC_URI[sha256sum] = "1200dcc7e60fcdaf68618dba991917a47e41e67099e8b22143976ec972e2cad7"