linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-kirkwood_2.6.31.bb
blob690b214cbfb9ed90ef2b8e7e9533c2a3ea2c3403
1 DESCRIPTION = "Linux Kernel for Marvell Kirkwood based devices"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 COMPATIBLE_MACHINE = "openrd-base"
7 # SheevaPlug still needs testing
8 #COMPATIBLE_MACHINE = "(openrd-base|sheevaplug)"
10 require linux.inc
12 FILESPATHPKG_prepend = "linux-2.6.31:"
14 # Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
15 PV = "2.6.31"
17 # last commit at the time of release of upstream v2.6.31
18 SRCREV = "8cb424312d88810bb62edbeef42a510725ceb482"
20 SRC_URI = "git://git.marvell.com/orion.git;protocol=git \
21 file://defconfig"
23 SRC_URI_append_openrd-base = " file://openrd-base-enable-pcie.patch \
24 file://cpuidle-reenable-interrupts.patch \
25 file://0001-Squashfs-move-zlib-decompression-wrapper-code-into.patch \
26 file://0002-Squashfs-Factor-out-remaining-zlib-dependencies-int.patch \
27 file://0003-Squashfs-add-a-decompressor-framework.patch \
28 file://0004-Squashfs-add-decompressor-entries-for-lzma-and-lzo.patch \
29 file://0005-Squashfs-add-an-extra-parameter-to-the-decompressor.patch \
30 file://0006-Squashfs-add-LZMA-compression.patch \
31 file://0007-Squashfs-Make-unlzma-available-to-non-initramfs-ini.patch \
33 # update machine types list for ARM architecture, only for machines that need it
34 do_arm_mach_types() {
35 if test ${MACHINE} == openrd-base; then
36 curl -o mach-types "http://www.arm.linux.org.uk/developer/machines/download.php" && \
37 cp mach-types arch/arm/tools/mach-types
41 addtask arm_mach_types after do_patch before do_configure
43 S = "${WORKDIR}/git"
45 KERNEL_IMAGETYPE ?= "uImage"