linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-jlime-ben-nanonote_2.6.36.bb
blob3df3f633501ed9e5f63e0f5c56e4cb392e1eac60
1 DESCRIPTION = "Linux 2.6.36 kernel for the Ben Nanonote"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 DEPENDS += "u-boot-mkimage-native"
7 SRCREV = "${AUTOREV}"
9 DEFAULT_PREFERENCE_ben-nanonote = "1"
10 COMPATIBLE_MACHINE = "ben-nanonote"
12 KERNEL_IMAGETYPE = "vmlinux.bin"
14 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kristoffer/linux-hpc.git;protocol=git;branch=v2.6.36-hpc \
15 file://logo_linux_clut224.tar.gz \
16 file://modifier-keys.patch \
17 file://config-ben-nanonote \
18 file://jz4740-udc.patch"
20 S = "${WORKDIR}/git"
22 inherit kernel
24 FILES_kernel-image = "/boot/uImage*"
26 do_configure_prepend() {
27 install -m 0644 ${WORKDIR}/config-ben-nanonote ${S}/.config
28 mv -f ${WORKDIR}/logo_linux_clut224.ppm ${S}/drivers/video/logo
31 do_install_append() {
32 cd ${S}
33 kernel_entry=`nm vmlinux | grep " kernel_entry" | cut -d' ' -f1`
35 cd ${S}/arch/mips/boot
36 rm -f vmlinux.bin.gz
37 gzip -c9 vmlinux.bin > vmlinux.bin.gz
39 mkimage -A mips -O linux -T kernel -C gzip -a 0x80010000 -e 0x${kernel_entry} \
40 -n 'MIPS' -d vmlinux.bin.gz uImage-${KERNEL_VERSION}
42 install -m 0644 uImage-${KERNEL_VERSION} ${D}/boot
45 pkg_postinst_kernel() {
46 cd /${KERNEL_IMAGEDEST}; update-alternatives --install /${KERNEL_IMAGEDEST}/uImage uImage uImage-${KERNEL_VERSION} ${KERNEL_PRIORITY} || true
49 pkg_postrm_kernel() {
50 cd /${KERNEL_IMAGEDEST}; update-alternatives --remove uImage uImage-${KERNEL_VERSION} || true