linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-h6300-omap1_2.6.14.3.bb
blob0832aa6442683ed0705be727d4fcd71d74cc369f
1 DESCRIPTION = "Linux kernel for h6300 devices."
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.14.tar.bz2;name=kernel \
6 http://www.muru.com/linux/omap/patches/old/patch-2.6.14-omap2.bz2;apply=yes;name=patch \
7 file://patch-linux-2614-omap2-to-2614_3-omap1-h6300;apply=yes \
8 file://defconfig"
10 S = "${WORKDIR}/linux-2.6.14"
12 inherit kernel
14 COMPATIBLE_MACHINE = "h6300"
16 do_configure_prepend() {
17 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
18 oe_runmake oldconfig
21 SRC_URI[kernel.md5sum] = "66d02cbd723876c6d69846a067875a22"
22 SRC_URI[kernel.sha256sum] = "cc56285834bed461fd405c00a34d3c3095673333b94621580eeeb0c65237af15"
23 SRC_URI[patch.md5sum] = "f9c9b0fe2ce0eef71c50ef45ddd0075d"
24 SRC_URI[patch.sha256sum] = "e4ac37531a455776ace04e234001c2849cbe2b1a3563409d23e4a6b3390c3e2d"