linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-efika_2.6.20.bb
blob9bbd76e202f16a49c4e33e4d98af489a01129808
1 DESCRIPTION = "Linux Kernel for the EFIKA dev platform"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 PR = "r2"
6 COMPATIBLE_MACHINE = "efika"
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
9 file://0001-powerpc-serial-Dispose-irq-mapping-when-done-in-mpc52xx_serial.c.txt;p=1;apply=yes \
10 file://0003-powerpc-Add-device-tree-fixups-for-the-EFIKA.txt;p=1;apply=yes \
11 file://0004-powerpc-Use-common-52xx-of_platform-probe-code-for-EFIKA.txt;p=1;apply=yes \
12 file://0005-powerpc-Restore-proper-link-order-in-platform.txt;p=1;apply=yes \
13 file://0006-Rework-the-OHCI-quirk-mecanism-as-suggested-by-David.txt;p=1;apply=yes \
14 file://0007-Implement-support-for-split-endian-OHCI.txt;p=1;apply=yes \
15 file://0008-ohci-Rework-bus-glue-integration-to-allow-several-at-once.txt;p=1;apply=yes \
16 file://0009-ohci-Add-support-for-OHCI-controller-on-the-of_platform-bus.txt;p=1;apply=yes \
17 file://0010-libata-Add-support-for-the-MPC52xx-ATA-controller.txt;p=1;apply=yes \
18 file://0011-ohci-Whitespace-and-typo-fix-in-ohci-ppc-of.c.txt;p=1;apply=yes \
19 file://0012-ata-Fix-pata_mpc52xx.c-compatible-list.txt;p=1;apply=yes \
20 file://0013-powerpc-serial-Fix-mpc52xx_uart.c-compatible-list.txt;p=1;apply=yes \
21 file://0014-powerpc-Small-cleanup-of-EFIKA-platform.txt;p=1;apply=yes \
22 file://0015-powerpc-Add-a-unified-uevent-handler-for-bus-based-on-of_device.txt;p=1;apply=yes \
23 file://0016-macintosh-Use-the-new-of_device-common-uevent-handler.txt;p=1;apply=yes \
24 file://0017-powerpc-Add-uevent-handler-for-of_platform_bus.txt;p=1;apply=yes \
25 file://0018-powerpc-Add-uevent-handler-for-ibmebus.txt;p=1;apply=yes \
26 file://0019-MPC5200-Bestcomm-platform-driver.txt;p=1;apply=yes \
27 file://0020-Fec-MPC5200-eth-driver.txt;p=1;apply=yes \
28 file://0021-POWERPC-Copy-bestcomm-support-files-into-arch-powerpc.txt;p=1;apply=yes \
29 file://0022-MPC52xx-PCI-now-working-on-lite5200.-ugly-but-working.txt;p=1;apply=yes \
30 file://0023-POWERPC-Make-FEC-work-on-the-lite5200.txt;p=1;apply=yes \
31 file://0024-Add-missing-function-prototype.txt;p=1;apply=yes \
32 file://0025-POWERPC-Misc-EFIKA-fixups-for-rtas-chrp.txt;p=1;apply=yes \
33 file://0026-POWERPC-Cleanup-mpc52xx-PCI-support.txt;p=1;apply=yes \
34 file://0027-POWERPC-Change-name-of-mpc52xx-pci-support-file-in-Makefile.txt;p=1;apply=yes \
35 file://0028-POWERPC-Change-link-order-so-mpc52xx-fec-always-shows-up-as-eth0.txt;p=1;apply=yes \
36 file://0029-POWERPC-Fixup-pr_print-format-for-mpc52xx-pci-support.txt;p=1;apply=yes \
37 file://0030-POWERPC-Add-mpc52xx-lite5200-PCI-support.txt;p=1;apply=yes \
38 file://0031-sound-Add-support-for-the-MPC52xx-PSC-AC97-Link.txt;p=1;apply=yes \
39 file://0032-POWERPC-EFIKA-Adds-missing-interrupts-from-bestcomm-node.txt;p=1;apply=yes \
40 file://0033-EFIKA-fullduplex-prpl_aln.txt;p=1;apply=yes \
41 file://v4l.diff;p=1 \
43 file://defconfig \
47 S = "${WORKDIR}/linux-${PV}"
49 inherit kernel
51 export ARCH="powerpc"
54 do_configure() {
55 install -m 644 ${WORKDIR}/defconfig ${S}/.config
56 make ARCH=${ARCH} oldconfig
59 do_install_append () {
60 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
62 install -d $kerneldir/arch/
63 cp -pPR arch/ppc $kerneldir/arch/
64 cp -pPR arch/powerpc $kerneldir/arch/
66 install -d $kerneldir/include/asm
67 cp -pPR include/asm-powerpc $kerneldir/include/
68 cp -pPR include/asm-ppc $kerneldir/include/
71 SRC_URI[md5sum] = "34b0f354819217e6a345f48ebbd8f13e"
72 SRC_URI[sha256sum] = "2c14ada1ac7d272e03b430d3a530d60fc9ec69cc8252382aa049afba7d2b8558"