linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-bug20-linaro_2.6.35.bb
blob8b8a6ef4c6c6cadfc47456f8eee0727b16860066
1 require linux.inc
3 DESCRIPTION = "Linux kernel for BUG20 based on the Linaro kernel tree"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "bug20"
8 PR = "r1"
10 SRCREV = "42f43f4bd4a0b612b7bcad3414e42a507282fe8b"
13 SRC_URI = "git://github.com/buglabs/bug20-2.6.35-linaro.git;branch=master;protocol=git"
15 S = "${WORKDIR}/git"
17 do_configure_prepend() {
18 cp arch/arm/configs/omap3_buglabs_defconfig ${WORKDIR}/defconfig
21 do_configure_append() {
22 sed -i -e "s/CONFIG_LOCALVERSION=\"\"/CONFIG_LOCALVERSION=\"-${PR}\"/g" ${S}/.config
25 # Make BMI header files available for JNI
26 do_install_append() {
27 install -d ${D}${includedir}/linux/bmi/
28 install -m 0644 ${S}/include/linux/bmi/*.h ${D}${includedir}/linux/bmi/
30 install -d ${D}${sysconfdir}/
31 echo "BUG Kernel Information" > ${D}${sysconfdir}/kernelinfo
32 date >> ${D}${sysconfdir}/kernelinfo
33 whoami >> ${D}${sysconfdir}/kernelinfo
34 echo "git rev: ${SRCREV}" >> ${D}${sysconfdir}/kernelinfo
37 PACKAGES += "kernel-headers"
38 FILES_kernel-headers = "${includedir}/linux/bmi"
39 FILES_kernel-image += "${sysconfdir}/kernelinfo"
41 module_conf_g_file_storage = "options g_file_storage file=/dev/mmcblk1 removable=y"
42 module_autoload_g_file_storage = "g_file_storage"