omap3.inc: bump MACHINE_KERNEL_PR for beagleboard changes
[openembedded.git] / recipes / v86d / v86d_0.1.9.bb
blob5ff69aa60a8d8247ac35c7a8de0db7f6f1a4ea2b
1 DESCRIPTION = "User support binary for the uvesafb kernel module"
2 SRC_URI = "http://dev.gentoo.org/~spock/projects/uvesafb/archive/v86d-${PV}.tar.bz2 \
3 file://fbsetup"
4 DEPENDS = "virtual/kernel klcc-cross"
6 LICENSE = "GPLv2"
7 PR = "r1"
9 RRECOMMENDS_${PN} = "kernel-module-uvesafb"
11 PACKAGE_ARCH = "${MACHINE_ARCH}"
12 COMPATIBLE_HOST = 'i.86.*-linux'
14 INITSCRIPT_NAME = "fbsetup"
15 INITSCRIPT_PARAMS = "start 0 S ."
17 export CC=${TARGET_PREFIX}klcc
19 # klcc doesn't work with -isystem
20 export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
22 do_configure () {
23 ./configure --default
26 do_compile () {
27 KDIR="${STAGING_KERNEL_DIR}" make
30 do_install () {
31 install -d ${D}${base_sbindir}
32 install v86d ${D}${base_sbindir}/
34 install -d ${D}${sysconfdir}/init.d/
35 install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
38 inherit update-rc.d
39 SRC_URI[md5sum] = "ebbbc8e7013c9544b6ba6981add43831"
40 SRC_URI[sha256sum] = "8167dec4ff919cfd73f854bbd3244f05c2b867e014fa8298044ea7cfd66d18a8"