omap3.inc: bump MACHINE_KERNEL_PR for beagleboard changes
[openembedded.git] / recipes / uclibc / uclibc_0.9.30.bb
blob9b539bf64145824ff823b9bc6447de85205bb4c3
1 # UCLIBC_BASE should be the latest released revision of uclibc (that way
2 # the config files will typically be correct!) uclibc-cvs takes precedence
3 # over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
4 # try removing it
6 # UCLIBC_BASE can be set in a distro file, but whether this works depends
7 # on whether the base patches apply to the selected (SRCDATE) svn release.
9 UCLIBC_BASE ?= "0.9.30"
11 require uclibc-old.inc
12 PR = "${INC_PR}.2"
14 PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
16 SRC_URI += "file://uClibc.machine file://uClibc.distro \
17 file://arm-linuxthreads.patch \
18 file://linuxthreads-changes.patch \
19 file://pthread_atfork.patch \
20 file://uclibc_ldso_use_O0.patch \
21 file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch \
22 file://unifdef-fix.patch \
23 file://Use-__always_inline-instead-of-__inline__.patch \
25 #recent versions uclibc require real kernel headers
26 PACKAGE_ARCH = "${MACHINE_ARCH}"
28 #as stated above, uclibc needs real kernel-headers
29 #however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
30 KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
32 S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"
34 SRC_URI[uClibc-0.9.30.md5sum] = "e5766e2566e0297adebebbcc0aba1f2d"
35 SRC_URI[uClibc-0.9.30.sha256sum] = "67e7e6b983cd2caa163f177d5196282434ae1e18b7270495cd6c65f5c1549555"