omap3.inc: bump MACHINE_KERNEL_PR for beagleboard changes
[openembedded.git] / recipes / groff / groff_1.19.2.bb
bloba5d8766e1c01f61d49bf4d1e40e8660158b6c7ba
1 DESCRIPTION = "GNU roff"
2 SECTION = "base"
3 LICENSE = "GPL"
4 PR = "r6"
6 SRC_URI = "http://ftp.gnu.org/gnu/groff/groff-${PV}.tar.gz \
7 file://Makefile.in.patch \
8 file://Makefile.sub.patch \
9 file://groff.patch"
11 inherit autotools
13 PARALLEL_MAKE = ""
14 # prefix and exec-prefix are broken and the .in file is broken too
15 # and can't be autoreconf'ed, so specify every dir
16 EXTRA_OECONF="--without-x --prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}/info --with-appresdir=${D}${datadir}"
17 EXTRA_OEMAKE = "INSTALL_INFO=:"
19 do_configure() {
20 oe_runconf
24 # The installer refuses to do anything if the prefix directory does not
25 # already exist, so create it manually before the standard install runs.
27 do_install_prepend() {
28 install -m 0755 -d ${D}
30 BBCLASSEXTEND = "native"
32 SRC_URI[md5sum] = "f7c9cf2e4b9967d3af167d7c9fadaae4"
33 SRC_URI[sha256sum] = "d864fbd0bf6dea24e4f71736da9902a1cae86d0a1a893b5fe17118927257ec3e"