mono-1.9.1: first pass at adding mono 1.9.1 to OE
[openembedded.git] / packages / totem / totem_1.0.4.bb
bloba12f307ffaa35f26e71b17a9608eca607ba29dc2
1 SECTION = "x11/multimedia"
2 # totem OE build file
3 # Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
4 # Released under the MIT license (see packages/COPYING)
6 DESCRIPTION="A GTK2 based media player"
7 HOMEPAGE="http://www.gnome.org/projects/totem/"
8 LICENSE="GPL"
10 SRC_URI="http://ftp.gnome.org/pub/GNOME/sources/totem/1.0/totem-${PV}.tar.gz \
11 file://include.patch;patch=1 \
12 file://omf.patch;patch=1 \
13 file://nonautilus.patch;patch=1 \
14 file://intl.patch;patch=1 \
15 file://cflags.patch;patch=1 \
16 file://gtkonly.patch;patch=1"
18 DEPENDS="gtk+ libglade gnome-vfs gconf libxine-x11 libxml2"
20 inherit autotools
22 EXTRA_OECONF="--disable-schemas-install --disable-nvtv --enable-gtk --disable-debug --disable-gstreamer --disable-mozilla"
24 #SELECTED_OPTIMIZATION="-O0 -g"
25 LDFLAGS_append = " -Wl,--export-dynamic"
27 pkg_postinst_totem() {
28 #!/bin/sh
29 if [ -n "$D" ]; then exit 1; fi;
30 SOURCE=`gconftool-2 --get-default-source`
31 GCONF_CONFIG_SOURCE=$SOURCE gconftool-2 --makefile-install-rule \
32 /etc/gconf/schemas/totem.schemas > /dev/null