mono-1.9.1: first pass at adding mono 1.9.1 to OE
[openembedded.git] / packages / tar / tar_1.13.93.bb
blob6c7139595f882f90de96e2d237704c575531b643
1 SECTION = "base"
2 DESCRIPTION = "GNU tar saves many files together into a single tape \
3 or disk archive, and can restore individual files from the archive."
4 LICENSE = "GPL"
5 PR = "r1"
7 SRC_URI = "ftp://alpha.gnu.org/gnu/tar/tar-${PV}.tar.gz \
8 file://configure.patch;patch=1 \
9 file://m4.patch;patch=1"
11 inherit autotools
13 do_install () {
14 autotools_do_install
15 install -d ${D}${base_bindir}
16 mv ${D}${bindir}/tar ${D}${base_bindir}/tar.${PN}
17 mv ${D}${libexecdir}/rmt ${D}${libexecdir}/rmt.${PN}
20 pkg_postinst_${PN} () {
21 update-alternatives --install ${base_bindir}/tar tar tar.${PN} 100
22 update-alternatives --install ${libexecdir}/rmt rmt rmt.${PN} 100
25 pkg_prerm_${PN} () {
26 update-alternatives --remove tar tar.${PN}
27 update-alternatives --remove rmt rmt.${PN}