mono-1.9.1: first pass at adding mono 1.9.1 to OE
[openembedded.git] / packages / hibernate-script / hibernate-script_1.12.bb
blob3d6f428d9049dd0ccb00070161e62732025d32cf
1 # hibernate-script OE build file
2 # Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 DESCRIPTION="Hibernate script supporting multiple suspend methods"
6 LICENSE="GPL"
7 HOMEPAGE="http://www.suspend2.net"
9 SRC_URI="http://www.suspend2.net/downloads/all/${PN}-${PV}.tar.gz \
10 file://hibernate.conf \
11 file://standby.conf \
12 file://ram.conf"
14 inherit update-rc.d
16 INITSCRIPT_NAME = "hibernate-cleanup"
17 INITSCRIPT_PARAMS = "start 31 S ."
19 FILES_${PN}_append = " /usr/share/hibernate"
21 do_install () {
22 BASE_DIR=${D} PREFIX=/usr MAN_DIR=${D}/usr/share/man \
23 ${S}/install.sh
25 ln -s ./hibernate ${D}/usr/sbin/hibernate-standby
26 ln -s ./hibernate ${D}/usr/sbin/hibernate-ram
28 #Override conf files from ${WORKDIR}
29 install -m 0644 ${WORKDIR}/hibernate.conf ${D}/etc/hibernate/
30 install -m 0644 ${WORKDIR}/ram.conf ${D}/etc/hibernate/
31 install -m 0644 ${WORKDIR}/standby.conf ${D}/etc/hibernate/
33 install -d ${D}/etc/init.d
34 install -m 0755 ${S}/init.d/hibernate-cleanup.sh ${D}/etc/init.d/hibernate-cleanup