mono-1.9.1: first pass at adding mono 1.9.1 to OE
[openembedded.git] / packages / hfsutils / hfsutils_3.2.6.bb
blob5292ac386c78c530192200e27f534f96f3ad4982
1 DESCRIPTION = "HFS file system utilities"
2 SECTION = "base"
3 LICENSE = "GPL"
4 PR = "r2"
6 inherit autotools pkgconfig
8 SRC_URI = "ftp://ftp.mars.org/pub/hfs/hfsutils-3.2.6.tar.gz \
9 file://hfsutils-3.2.6-errno.patch;patch=1 \
10 file://largerthan2gb.patch;patch=1 \
13 do_configure () {
14 oe_runconf --disable-x
17 do_compile () {
18 oe_runmake
19 cd hfsck; oe_runmake
22 do_install () {
23 install -d ${D}/${bindir}
24 install -m 755 hfsutil ${D}/${bindir}/hfsutil
25 install -m 755 hfsck/hfsck ${D}/${bindir}/hfsck
27 for util in hattrib hcd hcopy hdel hdir hformat \
28 his hmkdir hmount hpwd hrename hrmdir \
29 humount hvol; do
30 ln -sf hfsutil ${D}/${bindir}/${util}
31 done