task-base: make it possible for a distro to set it's alsa-state provider
[openembedded.git] / recipes / recode / recode_3.6.bb
blobd53cae87637a31b65ef74dcdff6bf0a82791df05
1 DESCRIPTION = "Charset converting utility"
2 SECTION = "console/utils"
3 LICENSE = "GPL"
5 PR = "r1"
6 SRC_URI = "${DEBIAN_MIRROR}/main/r/recode/recode_${PV}.orig.tar.gz \
7 file://recode-bitfield-width.patch"
9 inherit autotools
11 TARGET_CC_ARCH += "${LDFLAGS}"
13 do_configure() {
14 gnu-configize
15 oe_runconf
16 echo "#undef malloc" >>config.h
17 echo "#undef realloc" >>config.h
20 do_stage() {
21 install -m 0644 src/recode.h ${STAGING_INCDIR}/
22 install -m 0644 src/recodext.h ${STAGING_INCDIR}/
23 oe_libinstall -a -C src librecode ${STAGING_LIBDIR}/
27 SRC_URI[md5sum] = "be3f40ad2e93dae5cd5f628264bf1877"
28 SRC_URI[sha256sum] = "e3e6a4f3f8e5c6052ab70155990c074d87aa0b614fc1be31d194750d1d962fcf"