java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / opkg / opkg-nogpg_svn.bb
blobbee639ff8c8a23c68c87613fbdb195ce499c5824
1 require opkg_svn.bb
3 DEPENDS = "curl"
4 PROVIDES += "opkg"
6 PR = "${INC_PR}.1"
8 EXTRA_OECONF += " --disable-gpg \
9 --disable-openssl \
10 --disable-ssl-curl \
11 --enable-gpg=no \
12 --enable-ssl-curl=no \
13 --enable-openssl=no"
15 LDFLAGS_append = " -Wl,--as-needed"
17 # The nogpg version isn't getting much love and has an unused variable which trips up -Werror
18 do_configure_prepend() {
19 sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
21 do_configure_prepend_nylon() {
22 LDFLAGS="`echo "$LDFLAGS" | sed "s/ -Wl,--as-needed//"`"
25 DEFAULT_PREFERENCE = "-1"