1 require mtd
-utils_1.2
.0+git.bb
3 # this can probably be integrated into the main mtd
-utils package
4 # but I did
not want
to risk breakage
-- but would be glad
to
5 # integrate them
if that is best
-- cbrake
7 SRC_URI
= "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG}"
11 S
= "${WORKDIR}/git/tests/fs-tests"
13 FILES_$
{PN
} = "${datadir}/mtd-utils"
16 make || die
"Make failed"
33 stress/atoms/fwrite00 \
34 stress/atoms/gcd_hupper \
36 stress/atoms/rmdir00 \
37 stress/atoms/rndrm00 \
38 stress/atoms/rndrm99 \
39 stress/atoms/rndwrite00 \
40 stress/atoms/stress_1 \
41 stress/atoms/stress_2 \
42 stress/atoms/stress_3 \
44 utils/fstest_monitor \
48 install
-d $
{D
}$
{datadir
}/mtd
-utils
/tests
49 install
-d $
{D
}$
{datadir
}/mtd
-utils
/tests
/integrity
50 install
-d $
{D
}$
{datadir
}/mtd
-utils
/tests
/simple
51 install
-d $
{D
}$
{datadir
}/mtd
-utils
/tests
/stress
52 install
-d $
{D
}$
{datadir
}/mtd
-utils
/tests
/stress
/atoms
53 install
-d $
{D
}$
{datadir
}/mtd
-utils
/tests
/utils
54 for app in $
{mtd_utils_tests
}; do
55 install
-m
0755 $app $
{D
}$
{datadir
}/mtd
-utils
/tests
/$app