java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / meta / run-postinsts_1.0.bb
blob79333dc7feb3bf82366b6d46ead1e4aa49811f53
1 DESCRIPTION = "Run postinstall scripts on device using awk"
2 SECTION = "devel"
3 PR = "r6"
5 SRC_URI = "file://run-postinsts file://run-postinsts.awk"
7 INITSCRIPT_NAME = "run-postinsts"
8 INITSCRIPT_PARAMS = "start 98 S ."
10 inherit update-rc.d
12 do_configure() {
16 do_compile () {
20 do_install() {
21 install -d ${D}${sysconfdir}/init.d/
22 install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
24 install -d ${D}${datadir}/${PN}/
25 install -m 0644 ${WORKDIR}/run-postinsts.awk ${D}${datadir}/${PN}/
28 do_stage () {