java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / linux / linux-kirkwood_2.6.33-rc5.bb
blobcae7554077a12616f5adab2e40b8e64f265d38ae
1 DESCRIPTION = "Linux Kernel for Marvell Kirkwood based devices"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 COMPATIBLE_MACHINE = "openrd-base|openrd-client|sheevaplug"
7 require linux.inc
9 # Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
10 PV = "2.6.32+2.6.33-rc5"
12 SRCREV = "6a18e42f474250ab3cf7705f34b048c6d55797e5"
14 SRC_URI = "git://repo.or.cz/linux-2.6/linux-2.6-openrd.git;protocol=git \
15 file://defconfig"
17 SRC_URI_append_openrd-base += " \
18 file://0004-ARM-Kirkwood-OpenRD-base-SD-UART1-selection.patch;patch=1 \
21 SRC_URI_append_openrd-client += " \
22 file://0001-OpenRD-Client-PCIe-Initialize-PCI-express-and-i2c.patch;patch=1 \
23 file://0002-OpenRD-Client-Volari-Z11-driver-added.patch;patch=1 \
24 file://0003-ARM-Kirkwood-Sound-Sound-driver-added.patch;patch=1 \
25 file://0004-ARM-Kirkwood-OpenRD-SD-UART1-selection.patch;patch=1 \
28 # update machine types list for ARM architecture, only for machines that need it
29 do_arm_mach_types() {
30 # if test ${MACHINE} == openrd-base || test ${MACHINE} == openrd-client; then
31 curl -o mach-types "http://www.arm.linux.org.uk/developer/machines/download.php" && \
32 cp mach-types arch/arm/tools/mach-types
33 # fi
36 addtask arm_mach_types after do_patch before do_configure
38 S = "${WORKDIR}/git"
40 KERNEL_IMAGETYPE ?= "uImage"