java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / linux / linux-geodelx_2.6.11.bb
blobae58c2cfedff47a21539a52f4635dab6525c435f
1 # Linux kernel OE build file for the AMD Geode GX5535/LX5536
2 # Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 COMPATIBLE_MACHINE = "geodelx"
7 DESCRIPTION = "Linux kernel for the AMD Geode GX5535/LX5536"
8 HOMEPAGE = "http://www.amd.com/embedded"
9 LICENSE = "GPLv2"
11 PR = "r0"
12 AMD_DRIVER_VERSION = "02.03.0100"
13 AMD_DRIVER_LABEL = "Patches_Linux2.6.11_Common_${AMD_DRIVER_VERSION}"
15 KV = "${PV}"
17 S = "${WORKDIR}/linux-${KV}"
19 inherit kernel
21 ARCH = "i386"
23 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KV}.tar.bz2;name=kernel \
24 http://www.amd.com/files/connectivitysolutions/geode/geode_lx/${AMD_DRIVER_LABEL}.patch;patch=1;name=patch \
25 file://defconfig"
27 do_configure_prepend() {
29 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
32 SRC_URI[kernel.md5sum] = "f00fd1b5a80f52baf9d1d83acddfa325"
33 SRC_URI[kernel.sha256sum] = "1fa39c202efe168bfeb0ddd74c8e4814f77da7dc78993e47826bad9173b95808"
34 SRC_URI[patch.md5sum] = "e26f719ad845910de35ab123e548794b"
35 SRC_URI[patch.sha256sum] = "7bae2d456ede67312e1b34e4bfc277af7331e0eee55b95226de392e2d4fee340"