java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / cyrus-sasl / cyrus-sasl_2.1.18.bb
blob7c4532e4e67f771d4d445585739ef02be84179c2
1 SECTION = "console/network"
2 DEPENDS = "virtual/db"
3 DESCRIPTION = "Generic client/server library for SASL authentication."
4 LICENSE = "BSD"
6 PR = "r1"
8 SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/OLD-VERSIONS/sasl/cyrus-sasl-${PV}.tar.gz"
10 inherit autotools
12 acpaths = "-I ${S}/cmulocal -I ${S}/config -I ."
13 CFLAGS_append = " -I${S}/include -I${S}/saslauthd/include"
14 EXTRA_OECONF = "--enable-shared --enable-static --with-dblib=berkeley \
15 --with-bdb-libdir=${STAGING_LIBDIR} \
16 --with-bdb-incdir=${STAGING_INCDIR} \
17 --without-opie --without-des"
19 do_configure_prepend () {
20 rm -f acinclude.m4 config/libtool.m4
23 do_compile_prepend () {
24 cd include
25 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
26 touch makemd5.o makemd5.lo makemd5
27 cd ..
30 do_stage () {
31 oe_libinstall -so -a -C lib libsasl2 ${STAGING_LIBDIR}
32 install -d ${STAGING_LIBDIR}/sasl
33 install -d ${STAGING_INCDIR}/sasl
34 install -m 0644 ${S}/include/hmac-md5.h ${STAGING_INCDIR}/sasl/
35 install -m 0644 ${S}/include/md5.h ${STAGING_INCDIR}/sasl/
36 install -m 0644 ${S}/include/md5global.h ${STAGING_INCDIR}/sasl/
37 install -m 0644 ${S}/include/sasl.h ${STAGING_INCDIR}/sasl/
38 install -m 0644 ${S}/include/saslplug.h ${STAGING_INCDIR}/sasl/
39 install -m 0644 ${S}/include/saslutil.h ${STAGING_INCDIR}/sasl/
40 install -m 0644 ${S}/include/prop.h ${STAGING_INCDIR}/sasl/
43 SRC_URI[md5sum] = "1eafae95f0289c10f187d8b2bc4032cf"
44 SRC_URI[sha256sum] = "384279adfd582ad6f905197c46a5157f855462718530148fdbab3328cf621eb7"