java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / cpusage / cpusage_0.1.bb
blob9f5d9a4d9ba8771d7c123a45334920c7b6535cd3
1 DESCRIPTION = "This tool read out the tics counter of the operating system and \
2 calculates the Percentages spend in each CPU_STATE."
3 SECTION = "base"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
7 SRC_URI = "http://www8.in.tum.de/~schneifa/group/sources/cpusage-${PV}.tar.gz \
8 file://cpusage.patch;patch=1"
10 S = "${WORKDIR}/cpusage-${PV}"
12 FILES_${PN} = "/sbin/cpusage"
14 CFLAGS_append =" -D_BSD_SOURCE=1"
15 CFLAGS_append = '${@base_conditional("KERNEL_MAJOR_VERSION", "2.6", " -D__Linux26__ ", " -D__Linux24__ ",d)}'
17 do_compile() {
18 ${CC} ${CFLAGS} ${LDFLAGS} -o cpusage cpusage.c
21 do_install() {
22 install -d ${D}${base_sbindir}
23 install -m 0755 cpusage ${D}${base_sbindir}/cpusage
26 SRC_URI[md5sum] = "f779140995280de32817ec4a133f4d60"
27 SRC_URI[sha256sum] = "feb0b8c73c771390a8771fc3a4ed01104c008bcd278a267eb00263794956778c"