java-native.bbclass: remove do_stage function, because of NATIVE_INSTALL_WORKS =...
[openembedded.git] / recipes / bluez / bluez4_4.37.bb
blob6ec1b1c282952258e3bd27bbf7fa67149722cd0f
1 DESCRIPTION = "Linux Bluetooth Stack Userland V4"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 DEPENDS = "gst-plugins-base alsa-lib virtual/libusb0 dbus-glib"
5 HOMEPAGE = "http://www.bluez.org"
6 LICENSE = "GPL"
8 # For angstrom we want this to replace at least bluez-libs
9 PROVIDES_append_angstrom = " bluez-utils bluez-libs"
11 # temporary solution for KaeilOS just to replace at least bluez-libs
12 PROVIDES_append_angstrom = " bluez-utils bluez-libs"
14 PR = "r1"
16 SRC_URI = "\
17 http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
18 file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
19 file://sbc-thumb.patch;patch=1 \
20 file://bluetooth.conf \
22 S = "${WORKDIR}/bluez-${PV}"
24 inherit autotools_stage
25 AUTOTOOLS_STAGE_PKGCONFIG = "1"
27 EXTRA_OECONF = "\
28 --enable-gstreamer \
29 --enable-alsa \
30 --enable-usb \
31 --enable-netlink \
32 --enable-tools \
33 --enable-bccmd \
34 --enable-hid2hci \
35 --enable-dfutool \
36 --enable-hidd \
37 --enable-pand \
38 --enable-dund \
39 --disable-cups \
40 --enable-test \
41 --enable-manpages \
42 --enable-configfiles \
43 --enable-initscripts \
44 --disable-pcmciarules \
47 do_install_append() {
48 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
49 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
50 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
51 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
52 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
55 PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
57 FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
58 FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
59 FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
60 FILES_${PN}-dev += "\
61 ${libdir}/bluetooth/plugins/*.la \
62 ${libdir}/alsa-lib/*.la \
63 ${libdir}/gstreamer-0.10/*.la \
66 FILES_${PN}-dbg += "\
67 ${libdir}/bluetooth/plugins/.debug \
68 ${libdir}/*/.debug \
71 SRC_URI[md5sum] = "c1106f56f8e5562cf7c49d3455d2c5f7"
72 SRC_URI[sha256sum] = "2bfc5db7703cbcaaa4be2576609136450e1dac5d4782707dd0dc81754e3c2489"