angstrom-systemd-image: small image with systemd as init manager
[openembedded.git] / recipes / scim / scim_1.4.9.bb
blob21110b2a4593d0f4e50dccdb934d06220b7e67cd
1 DESCRIPTION = "Smart Common Input Method (SCIM) platform"
2 HOMEPAGE = "http://www.scim-im.org"
3 SECTION = "libs/inputmethod"
4 LICENSE = "LGPLv2.1+"
5 DEPENDS = "gtk+ cairo"
6 PR = "r2"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
9 file://gcc-4.4-const-char.dpatch;apply=yes \
10 file://configure.patch \
11 file://20_scim_config.dpatch;apply=yes \
12 file://40_scim_user_home_overrides.dpatch;apply=yes \
13 file://50_validate-desktop-entry.dpatch;apply=yes \
14 file://51_scim-1.4.7-fix-capslock.dpatch;apply=yes \
15 file://52_scim-1.4.7-imdkit-read-property-properly.dpatch;apply=yes \
16 file://53_scim-1.4.7-trayicon.dpatch;apply=yes \
17 file://54_scim-1.4.7-xim-wrong-format.dpatch;apply=yes \
18 file://scim-1.4.7-syslibltdl.patch \
21 inherit autotools pkgconfig
22 EXTRA_OECONF = " --without-doxygen "
23 LEAD_SONAME = "libscim-1.0.so"
25 PDIR = "${PN}-1.0"
27 do_configure_append () {
28 # Fix unset @ALL_LINGUAS@
29 # Replace with a list of available translations in ${S}/po
31 cd ${S}/po
32 SEDR=`ls *.gmo -1 --color=none | sed 's/.gmo//' | tr '\n' ' '`
33 SEDL='@ALL_LINGUAS@'
34 sed -i "s/${SEDL}.*/${SEDR}/" Makefile.in.in
35 sed -i "s/${SEDL}.*/${SEDR}/" Makefile.in
36 sed -i "s/${SEDL}.*/${SEDR}/" Makefile
37 # the below sed is done to prevent an infinite loop when make enters po/
38 # since intltoolize is not a knobbable operation in autotools do_configure
39 # good old sed comes to our rescue
40 # this is equivalent of a patch to Makefile.in.in which would be
41 #- $(SHELL) ./config.status
42 #+ $(SHELL) ./config.status
43 #+ touch stamp-it
45 sed -i 's/^[ \t]*\$(SHELL).*$/\t\$(SHELL) .\/config.status\n\ttouch stamp-it/g' Makefile.in.in
46 # Fix unset @INTLTOOL_LIBDIR@
47 # Only needed for a check to see if charmap.alias is present,
48 # not really needed, so we fail that test by having it look
49 # in ${S}
51 cd ${S}
52 sed -i 's/@INTLTOOL_LIBDIR@/./' intltool-merge.in
53 sed -i 's/@INTLTOOL_LIBDIR@/./' intltool-merge
55 # Fix unset @GTK_LIBDIR@
56 # This is the same as ${libdir} so we use that
58 cd ${S}/extras/gtk2_immodule
59 sed -i 's/@GTK_LIBDIR@/$(libdir)/g' Makefile.in
60 sed -i 's/@GTK_LIBDIR@/$(libdir)/g' Makefile.am
63 pkg_postinst_${PN} () {
64 # Update gtk2 immodules
65 # Adds SCIM to the list
66 /usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
69 pkg_postrm_${PN} () {
70 # Update gtk2 immodules
71 # Removes SCIM from the list
72 /usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
75 FILES_${PN}-dbg += "${libdir}/${PDIR}/.debug \
76 ${libdir}/${PDIR}/1.4.0/*/.debug \
77 ${libdir}/gtk-2.0/immodules/.debug"
78 FILES_${PN} += "${libdir}/${PDIR}/scim-panel-gtk \
79 ${libdir}/${PDIR}/scim-helper* \
80 ${libdir}/${PDIR}/scim-launcher \
81 ${libdir}/${PDIR}/1.4.0 \
82 ${libdir}/gtk-2.0/immodules"
84 SRC_URI[md5sum] = "975ba34b01304ea8166ac8ea27aa9e88"
85 SRC_URI[sha256sum] = "f72e9779e220565f6002923bf7d6aa9891be2bbddcd91a4e2a2d5e20aefba8d0"