angstrom-systemd-image: small image with systemd as init manager
[openembedded.git] / recipes / hplip / hplip_2.8.10.bb
blob52157967859d0e294b70f97299531a9c3e7c4395
1 DESCRIPTION = "HP Linux Imaging and Printing"
2 LICENSE = "GPL, MIT"
4 # currently, we build a stripped down version that only includes IJS
5 # and components required to implement a minimal printing system
6 # for embedded systems.
8 SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
9 file://cross-build.patch"
11 PR = "r1"
13 inherit autotools
15 EXTRA_OECONF = ' \
16 BUILD_SYS="" HOST_SYS="" \
17 --disable-network-build \
18 --disable-doc-build \
19 --disable-pp-build \
20 --disable-scan-build \
21 --disable-gui-build \
22 --disable-fax-build \
23 --disable-dbus-build \
24 --disable-foomatic-drv-install \
25 --disable-foomatic-rip-hplip-install \
28 # needed by python checks in configure
29 EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
31 PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend"
33 # need to snag the debug file or OE will fail on backend package
34 FILES_${PN}-dbg += "\
35 ${libdir}/cups/backend/.debug
37 FILES_${PN}-ppd = "\
38 ${datadir}/ppd"
40 FILES_${PN}-cups = "\
41 ${datadir}/cups"
43 FILES_${PN}-backend = "\
44 ${libdir}/cups/backend"
47 SRC_URI[md5sum] = "a9ad78c4f0d884caac6b176b3cb9bf21"
48 SRC_URI[sha256sum] = "8e34e2bc5974fd0f4ab71fbb42ac76fe3074fb2a09960452e4a1a157a77e00f1"