linux-2.6.34: remove c7x0 patch from SRC_URI override as that file was removed in...
[openembedded.git] / recipes / linux / linux-omap_git.bb
blobe74e8cf7541cfd2a704d66ba7db0ef7d07a8420c
1 require linux.inc
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom|omapzoom2|omap4430-sdp"
8 DEFAULT_PREFERENCE = "-1"
10 SRCREV = "945044d157dd63c6af0f2ed40a5346382af94eb4"
12 FILESPATHPKG_prepend = "linux-omap-2.6.31:"
14 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
15 #PV = "2.6.30+2.6.31-rc8+gitr${SRCREV}"
16 PV = "2.6.31"
18 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
19 file://defconfig"
21 SRC_URI_append = " \
22 file://ehci.patch \
23 file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch \
24 file://cache/l1cache-shift.patch \
25 file://cache/copy-page-tweak.patch \
26 file://dss2/0001-OMAP2-Add-funcs-for-writing-SMS_ROT_-registers.patch \
27 file://dss2/0002-OMAP-OMAPFB-split-omapfb.h.patch \
28 file://dss2/0003-OMAP-OMAPFB-add-omapdss-device.patch \
29 file://dss2/0004-OMAP-Add-VRAM-manager.patch \
30 file://dss2/0005-OMAP-Add-support-for-VRFB-rotation-engine.patch \
31 file://dss2/0006-OMAP-DSS2-Documentation-for-DSS2.patch \
32 file://dss2/0007-OMAP-DSS2-Display-Subsystem-Driver-core.patch \
33 file://dss2/0008-OMAP-DSS2-Add-more-core-files.patch \
34 file://dss2/0009-OMAP-DSS2-DISPC.patch \
35 file://dss2/0010-OMAP-DSS2-DPI-driver.patch \
36 file://dss2/0011-OMAP-DSS2-Video-encoder-driver.patch \
37 file://dss2/0012-OMAP-DSS2-RFBI-driver.patch \
38 file://dss2/0013-OMAP-DSS2-SDI-driver.patch \
39 file://dss2/0014-OMAP-DSS2-DSI-driver.patch \
40 file://dss2/0015-OMAP-DSS2-omapfb-driver.patch \
41 file://dss2/0016-OMAP-DSS2-Add-DPI-panel-drivers.patch \
42 file://dss2/0017-OMAP-DSS2-Taal-DSI-command-mode-panel-driver.patch \
43 file://dss2/0001-OMAP3-Enable-DSS2-for-OMAP3EVM-board.patch \
44 file://dss2/0002-V4L2-Added-New-V4L2-CIDs-for-omap-devices-V4L2-IOCT.patch \
45 file://dss2/0003-V4L2-Updated-v4l2_common-for-new-V4L2-CIDs.patch \
46 file://dss2/0004-OMAP2-3-V4L2-Add-support-for-OMAP2-3-V4L2-driver-on.patch \
47 file://expansion-boards/tincantools-zippy.patch \
48 file://madc/madc-driver.patch \
49 file://madc/madc.patch \
50 file://arch-has-holes.diff \
51 file://usb/0001-musb-fix-put_device-call-sequence.patch \
52 file://usb/0008-omap3-Add-CHIP_GE_OMAP3430ES3-for-HSUSB.patch \
53 file://usb/0011-musb-fix-musb-gadget_driver-NULL-bug.patch \
54 file://usb/0012-musb-Add-back-old-musb-procfs-file.patch \
55 file://usb/0013-musb-Remove-USB_SUSPEND-auto-select-with-OTG.patch \
56 file://usb/0014-musb-disable-PING-on-status-phase-of-control-transf.patch \
57 file://usb/0015-musb-Add-context-save-and-restore-support.patch \
58 file://usb/0016-usb-update-defconfig.patch \
59 file://usb/0001-ARM-OMAP-Fix-beagleboard-EHCI-setup.patch \
60 file://modedb-hd720.patch \
61 file://dss2/beagle-dss2-support.patch \
62 file://fix-serial.eml;apply=yes \
63 file://fix-omap4.diff \
66 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
69 S = "${WORKDIR}/git"
71 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"