linux-2.6.34: remove c7x0 patch from SRC_URI override as that file was removed in...
[openembedded.git] / recipes / linux / linux-omap_2.6.32.bb
blob348ec96fcb288bbd79b6fc193d15ff654377fb60
1 require linux.inc
3 DESCRIPTION = "Linux kernel for OMAP processors"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom|omapzoom2|omap4430-sdp|cm-t35"
8 DEFAULT_PREFERENCE = "-1"
9 DEFAULT_PREFERENCE_cm-t35 = "1"
11 SRCREV = "89c9eaeb92c97348dcabd6cb377b646c00855f6a"
13 # The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
14 PV = "2.6.32"
16 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
17 file://defconfig"
19 SRC_URI_append = " \
20 file://usb/ehci.patch \
21 file://usb/ehci-omap.c-mach-to-plat.diff \
22 file://cm-t35/0001-omap3-cm-t35-add-mux-initialization.patch \
23 file://cm-t35/0001-OMAP-DSS2-add-Toppoly-TDO35S-panel.patch \
24 file://cm-t35/0002-omap3-cm-t35-add-DSS2-display-support.patch \
25 file://cm-t35/0003-omap3-cm-t35-update-defconfig-for-DSS2.patch \
26 file://cm-t35/0004-omap3-cm-t35-add-cm-t35-mux-configs.patch \
27 file://cm-t35/0006-omap3-cm-t35-update-defconfig.patch \
28 file://cm-t35/0001-backlight-tdo24m-ensure-chip-select-changes-between-.patch \
29 file://0001-ARM-OMAP-Overo-Add-support-for-second-ethernet-po.patch \
30 file://0003-drivers-net-smsc911x-return-ENODEV-if-device-is-n.patch \
31 file://0004-drivers-input-touchscreen-ads7846-return-ENODEV.patch \
32 file://0005-ARM-OMAP-add-support-for-TCT-Zippy-to-Beagle-board.patch \
33 file://0006-ARM-OMAP-Make-beagle-u-boot-partition-writable.patch \
34 file://0007-ASoC-enable-audio-capture-by-default-for-twl4030.patch \
35 file://0009-MTD-NAND-omap2-proper-fix-for-subpage-read-ECC-error.patch \
36 file://madc/0009-drivers-mfd-add-twl4030-madc-driver.patch \
37 file://madc/0010-ARM-OMAP-Add-twl4030-madc-support-to-Overo.patch \
38 file://madc/0011-ARM-OMAP-Add-twl4030-madc-support-to-Beagle.patch \
39 file://madc/0013-ARM-OMAP-Add-missing-twl4030-madc-header-file.patch \
40 file://dss2/0012-OMAP-DSS2-Add-support-for-LG-Philips-LB035Q02-pane.patch \
41 file://dss2/0014-OMAP-DSS-Add-DSS2-support-for-Overo.patch \
42 file://dss2/0015-OMAP-DSS-Add-DSS2-support-for-Beagle.patch \
43 file://dss2/0016-video-add-timings-for-hd720.patch \
44 file://holes.patch \
47 SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
50 S = "${WORKDIR}/git"
52 module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"