linux-2.6.34: remove c7x0 patch from SRC_URI override as that file was removed in...
[openembedded.git] / recipes / linux / linux-mtx-1_2.4.27.bb
blobf5bd6ed0fa517d84d6edd32e30bb34268b4b9dd3
1 DESCRIPTION = "Linux kernel for MTX-1 (MeshCube)"
2 HOMEPAGE = "http://meshcube.org/meshwiki/"
3 LICENSE = "GPLv2"
4 KV = "${PV}"
5 PR = "r12"
6 inherit module-base kernel
8 PROVIDES = "virtual/kernel"
9 RDEPENDS_${PN} = "mtd-utils"
11 SRC_URI = "cvs://cvs:cvs@ftp.linux-mips.org/home/cvs;module=linux;tag=linux_2_4_27 \
12 file://01-mtd-2004-01-27.diff \
13 file://02-mtd-mtx-1-map.diff \
14 file://03-mtd-erase-compiler-bug.diff \
15 file://04-mtx-1-board-reset.diff \
16 file://05-mtx-1-pci-irq.diff \
17 file://06-zboot-2.4.26.patch \
18 file://07-zboot-zimage-flash-bin.diff \
19 file://08-usb-nonpci-2.4.24.patch \
20 file://09-au1000-eth-vlan.diff \
21 file://10-iw-max-spy-32.diff \
22 file://11-mtd-proc-partition-rw.diff \
23 file://12-openswan-2.2.0-nat-t.diff \
24 file://13-openswan-2.2.0.patch \
25 file://14-au1000-eth-link-beat.diff \
26 file://16-i2c.patch \
27 file://17-lmsensors.2.8.8.patch \
28 file://18-i2c-au1x00gpio.patch \
29 file://19-kernel-make-depend.diff \
30 file://20-au1x00_ethernet_tx_stats.diff \
31 file://21-mtx-1-watchdog.diff \
32 file://23-mtx-1_watchdog_autotrigger.patch \
33 file://24-mtx-1_sysbtn.patch \
34 file://25-mtx-sio2.diff \
35 file://26-usbd-amd-pb1x00-kit-23may2003-update.diff \
36 file://27-usbd-amd-pb1x00-kit-23may2003-usbd.diff \
37 file://29-au1000-pci-config-clear-errors.diff \
38 file://32-usbserial-stalled-hack.diff \
39 file://33-usbserial-bulk_in_size-4096.diff \
40 file://42-usb-ohci-fixes.patch \
41 file://43-usbserial-27-32-backport.diff \
42 file://45-acm-tty-and-sb2.patch \
43 file://48-pptp.patch \
44 file://49-bash4-configure.patch \
45 file://defconfig-mtx-1"
47 S = "${WORKDIR}/linux"
49 inherit kernel
51 COMPATIBLE_MACHINE = "mtx-1"
52 COMPATIBLE_HOST = "mipsel.*-linux"
53 ARCH = "mips"
54 KERNEL_OUTPUT = "arch/mips/zboot/images/mtx-1.flash.bin"
55 KERNEL_IMAGETYPE = "zImage.flash"
56 KERNEL_IMAGEDEST = "tmp"
58 MTX_KERNEL_NON_PCI_OHCI = "yes"
60 do_configure_prepend() {
61 install -m 0644 ${WORKDIR}/defconfig-mtx-1 ${S}/.config
62 if [ "x${MTX_KERNEL_NON_PCI_OHCI}" = "xyes" ]; then
63 echo "CONFIG_USB_NON_PCI_OHCI=y" >> ${S}/.config
67 pkg_postinst_kernel() {
68 if test "x$D" != "x"; then
69 exit 1
70 else
71 if test -e /tmp/zImage.flash-${KV}; then
72 echo "*** flashing kernel ***"
73 flashcp -v /tmp/zImage.flash-${KV} /dev/mtd/2
74 echo "*** done. please reboot ***"
79 FILES_kernel += " /tmp"
81 do_deploy() {
82 install -d 0755 ${DEPLOY_DIR_IMAGE}
83 install -m 0644 arch/mips/zboot/images/mtx-1.flash.bin ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.flash.bin
84 install -m 0644 arch/mips/zboot/images/mtx-1.flash.srec ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.flash.srec
85 install -m 0644 arch/mips/zboot/images/mtx-1.srec ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_NAME}.ram.srec