1 # Task packages are only used to pull in other packages
2 # via their dependencies. They are empty.
5 # By default, only the task package itself is in PACKAGES.
6 # -dbg and -dev flavours are handled by the anonfunc below.
7 # This means that task recipes used to build multiple task
8 # packages have to modify PACKAGES after inheriting task.bbclass.
11 # By default, task packages do not depend on a certain architecture.
12 # Only if dependencies are modified by MACHINE_FEATURES, packages
13 # need to be set to MACHINE_ARCH after inheriting task.bbclass
16 # This automatically adds -dbg and -dev flavours of all PACKAGES
17 # to the list. Their dependencies (RRECOMMENDS) are handled as usual
18 # by package_depchains in a following step.
21 packages = bb.data.getVar('PACKAGES', d, 1).split()
24 for postfix in ['-dbg', '-dev']:
25 genpackages.append(pkg+postfix)
26 bb.data.setVar('PACKAGES', ' '.join(packages+genpackages), d)