help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / xbmc / xbmc_svn.bb
blob3689715c9637f914d17f7fc54d61e7d5ff22941d
1 DESCRIPTION = "XBMC Media Center"
2 LICENSE = "xbmc"
4 DEPENDS = "libxmu fribidi mpeg2dec ffmpeg samba fontconfig curl python libmodplug libmicrohttpd wavpack libmms cmake-native libsdl-image libsdl-mixer virtual/egl mysql5 sqlite3 libmms faad2 libcdio libpcre boost lzo2 enca avahi libsamplerate0 libxinerama libxrandr libxtst bzip2 virtual/libsdl jasper zip-native zlib"
5 require recipes/egl/egl.inc
7 SRCREV = "e2ab481ebe964321c358ab9d6402088c714adcbe"
9 PV = "10.05"
10 PR = "r11"
11 PR_append = "+gitr${SRCPV}"
13 SRC_URI = "git://xbmc.git.sourceforge.net/gitroot/xbmc/xbmc;protocol=git;branch=master \
14 file://0001-Only-check-for-nasm-on-i686-it-is-bogus-on-ARM-which.patch \
15 file://0002-Exclude-gnu-configize-for-ngstr-m-Thanks-koen.patch \
16 file://0003-Workaround-to-compile-python-on-ngstr-m-with-Python-.patch \
17 file://0004-Don-t-use-sudo-in-install-of-xbmc.bin-not-all-distri.patch \
18 file://0005-Hardcode-arm7-for-now.patch \
19 file://0006-Hardcode-python2.6-for-now.patch \
20 file://0007-No-need-for-FEH-on-embedded-need-a-better-way-to-not.patch \
21 file://0008-configure.in-also-pass-down-target-when-using-host-a.patch \
22 file://0009-Added-a-configure-option-disable-optical-drive.patch \
23 file://0010-Fixed-so-compile-worked-when-disabling-optical.patch \
24 file://0011-reverted-so-normal-bootstrap-doesn-t-exclude-gnu-con.patch \
25 file://0012-fix-lzo-things.patch \
28 inherit autotools gettext
30 S = "${WORKDIR}/git"
32 EXTRA_OECONF = " \
33 --enable-gles \
34 --disable-optical-drive \
35 --enable-external-libraries \
38 do_configure() {
39 if [ -e bootstrap.angstrom ] ; then
40 sh bootstrap.angstrom
41 else
42 sh bootstrap
44 oe_runconf
47 do_compile_prepend() {
48 for i in $(find . -name "Makefil*") ; do
49 sed -i 's:I/usr/include:I${STAGING_INCDIR}:g' $i
50 done
51 for i in $(find . -name "*.mak*") ; do
52 sed -i 's:I/usr/include:I${STAGING_INCDIR}:g' $i
53 done
54 sed -i 's:I/usr/include:I${STAGING_INCDIR}:g' ${S}/Makefile
57 do_install_append() {
58 ln -sf ${libdir}/xbmc/system/python/python24-arm.so ${D}${datadir}/xbmc/system/python/ || true
59 ln -sf ${libdir}/xbmc/system/python/python26-arm.so ${D}${datadir}/xbmc/system/python/ || true
62 FILES_${PN} += "${datadir}/xsessions"
63 FILES_${PN}-dbg += "${libdir}/xbmc/.debug ${libdir}/xbmc/*/.debug ${libdir}/xbmc/*/*/.debug ${libdir}/xbmc/*/*/*/.debug"
65 # Only builds with glibc currently, so this is "safe"
66 RRECOMMENDS_${PN} += "glibc-charmap-ibm850 glibc-gconv-ibm850"
68 # GNU_HASH QA errors...
69 INSANE_SKIP_${PN} = "True"