help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / sbagen / sbagen_1.4.1.bb
blobf45248e2bfaa5458843474b1409894c1dec8ee37
1 DESCRIPTION = "Binaural tone generation tool."
2 HOMEPAGE = "http://uazu.net/sbagen/"
3 LICENSE = "GPL"
4 DEPENDS = "tremor"
6 SRC_URI = "http://uazu.net/sbagen/sbagen-${PV}.tgz"
7 S = "${WORKDIR}/sbagen-${PV}"
9 LIBS = "-lm -lpthread -lvorbisidec"
10 DEFS = "-DT_LINUX -DOGG_DECODE"
11 # LIBS = "-lm -lpthread -lmad"
12 # DEFS = "-DT_LINUX -DMP3_DECODE"
14 do_compile () {
15 ${CC} ${CFLAGS} ${DEFS} sbagen.c ${LDFLAGS} -o sbagen ${LIBS}
18 do_install () {
19 install -d ${D}${bindir}
20 install -m 0755 sbagen ${D}${bindir}/
23 SRC_URI[md5sum] = "7d672f2f2a8e33e664b06777459471fe"
24 SRC_URI[sha256sum] = "3190534f4449f810d633b0a9848c7db1458b4c57249432a3932a468ecb06daea"