help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / linux / linux_2.6.14.bb
bloba6352308c5717bfabe9bcef628a66cbb2d3df0d3
1 DESCRIPTION = "Linux Kernel"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 DEFAULT_PREFERENCE = "-1"
6 DEFAULT_PREFERENCE_acern30 = "1"
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
9 file://defconfig"
11 SRC_URI_append_acern30 = "\
12 http://rtp-net.org/ipaq/patches/2.6.14-3/v2.6.14-gitcurrent.patch;name=patch1 \
13 http://rtp-net.org/ipaq/patches/2.6.14-3/full.patch;name=patch2 \
14 file://n30-cleanup.patch \
15 file://n35.patch \
16 file://n30-lcd.patch \
17 file://n30-backlight.patch \
18 file://n30-ts.patch \
19 file://n30-buttons.patch \
20 file://n30-mmc.patch \
21 file://n30-mmc-power.patch \
22 file://n30-mmc-wprotect.patch \
23 file://n30-nand.patch \
24 file://n30-usbstart.patch \
25 file://n30-hardcode.patch \
26 file://n30-apm.patch \
27 file://s3c2410fb-resume.patch \
28 file://s3c2410_ts-pm.patch \
29 file://s3c2410_lcd-pm.c;apply=yes \
30 file://s3c2410mci-pm.patch \
31 file://s3c2410-nand-pm.patch \
32 file://n30-nand-hack.patch \
33 file://mmc-plus.patch \
34 file://gpio-sysfs.patch \
35 file://regdump.patch \
36 file://n30-pm.patch \
37 file://spi.patch \
38 file://wingel-hacking.patch \
39 file://gcc4-fixes.patch \
42 inherit kernel
44 do_configure_prepend() {
45 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
48 SRC_URI[kernel.md5sum] = "66d02cbd723876c6d69846a067875a22"
49 SRC_URI[kernel.sha256sum] = "cc56285834bed461fd405c00a34d3c3095673333b94621580eeeb0c65237af15"
51 SRC_URI[patch1.md5sum] = "e0b42e51630e9cd7e3b0adf1be42f4a1"
52 SRC_URI[patch1.sha256sum] = "0c625e90d13f91269d3a02ebdfba97226651a849ad8d69a0734bb5df7964c571"
53 SRC_URI[patch2.md5sum] = "d7ec27a9b44eed194426038640af5460"
54 SRC_URI[patch2.sha256sum] = "70e8e8230390fb355d62270764f18f6b553bcb9383ddabfbed4a1238b0e79b80"