help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / linux / linux-rp_2.6.25+2.6.26-rc4.bb
blob786a74ed52266ae1a9965653de53a240538db72f
1 require linux-rp.inc
3 PR = "r6"
5 DEFAULT_PREFERENCE = "-1"
6 DEFAULT_PREFERENCE_qemuarm = "1"
7 DEFAULT_PREFERENCE_qemux86 = "1"
8 DEFAULT_PREFERENCE_spitz = "1"
10 # Handy URLs
11 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
12 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
13 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
14 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;apply=yes
15 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;apply=yes
16 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;apply=yes
17 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;apply=yes
19 # Patches submitted upstream are towards top of this list
20 # Hacks should clearly named and at the bottom
21 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.25.tar.bz2;name=kernel \
22 ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/v2.6.26/patch-2.6.26-rc4.bz2;apply=yes;name=rc4patch \
23 ${RPSRC}/lzo_jffs2_sysfs-r1.patch;name=rppatch1 \
24 ${RPSRC}/hx2750_base-r34.patch;name=rppatch2 \
25 ${RPSRC}/hx2750_bl-r9.patch;name=rppatch3 \
26 ${RPSRC}/hx2750_pcmcia-r3.patch;name=rppatch4 \
27 ${RPSRC}/pxa_keys-r9.patch;name=rppatch5 \
28 ${RPSRC}/tsc2101-r19.patch;name=rppatch6 \
29 ${RPSRC}/hx2750_test1-r8.patch;name=rppatch7 \
30 ${RPSRC}/sharpsl_pm_fixes1-r0.patch;name=rppatch8 \
31 ${RPSRC}/pm_changes-r1.patch;name=rppatch9 \
32 ${RPSRC}/locomo_kbd_tweak-r2.patch;name=rppatch10 \
33 # ${RPSRC}/pxa27x_overlay-r8.patch;name=rppatch11 \
34 ${RPSRC}/w100_extaccel-r2.patch;name=rppatch12 \
35 ${RPSRC}/w100_extmem-r1.patch;name=rppatch13 \
36 ${RPSRC}/poodle_pm-r6.patch;name=rppatch14 \
37 ${RPSRC}/poodle_lcd_hack-r0.patch;name=rppatch15 \
38 ${RPSRC}/poodle_asoc_fix-r1.patch;name=rppatch16 \
39 ${RPSRC}/logo_oh-r1.patch.bz2;status=unmergable;name=rppatch17 \
40 ${RPSRC}/pxa-linking-bug.patch;status=unmergable;name=rppatch18 \
41 file://hostap-monitor-mode.patch;status=unmergable \
42 file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;status=unmergable \
43 ${RPSRC}/mmcsd_large_cards-r1.patch;status=hack;name=rppatch19 \
44 ${RPSRC}/mmcsd_no_scr_check-r2.patch;status=hack;name=rppatch20 \
45 ${RPSRC}/integrator_rgb-r1.patch;status=hack;name=rppatch21 \
46 ${RPSRC}/pxa_cf_initorder_hack-r1.patch;status=hack;name=rppatch22 \
47 file://sharpsl-rc-r1.patch \
48 file://spitz_h_rewrite.patch \
49 file://pxa-serial-hack.patch;status=hack \
50 file://connectplus-remove-ide-HACK.patch;status=hack \
51 file://connectplus-prevent-oops-HACK.patch;status=hack \
52 file://htcuni.patch \
53 file://versatile-armv6.patch \
54 file://defconfig-c7x0 \
55 file://defconfig-hx2000 \
56 file://defconfig-akita \
57 file://defconfig-spitz \
58 file://defconfig-qemuarm \
59 file://defconfig-qemux86 \
60 file://defconfig-bootcdx86 \
61 file://defconfig-htcuniversal \
62 file://defconfig-zylonite"
63 # Disabled until the patchset is updated:
64 # file://defconfig-tosa
65 # file://defconfig-collie
66 # file://defconfig-poodle
69 # FIXMEs before made default
70 # ${RPSRC}/mmcsd_no_scr_check-r1.patch;status=hack;name=rppatch50
73 # Add this to enable pm debug code (useful with a serial lead)
74 # ${RPSRC}/sharpsl_pm_debug-r0.patch;name=rppatch51
76 # Disabled until I find the reason this gives issues with cdc_subset
77 # ${RPSRC}/usb_rndis_tweaks-r0.patch;name=rppatch52 \
80 SRC_URI_append_collie = "\
81 ${TKSRC}/mtd-sharp-flash-hack-r4.patch;name=tkpatch1 \
82 ${TKSRC}/mcp-sa11x0-r0.patch;name=tkpatch2 \
83 ${TKSRC}/locomo-r1.patch;name=tkpatch3 \
84 ${TKSRC}/collie-kexec-r1.patch;name=tkpatch4 \
85 ${TKSRC}/sharpsl_pm-4.patch;name=tkpatch5 \
86 ${TKSRC}/collie_pm-3.patch;name=tkpatch6 \
87 ${TKSRC}/ucb1x00_suspend.patch;name=tkpatch7 \
88 ${TKSRC}/collie-ts.patch;name=tkpatch8 \
89 ${TKSRC}/pcmcia_suspend.patch;name=tkpatch9 \
90 ${TKSRC}/locomo_spi-6.patch;name=tkpatch10 \
91 ${TKSRC}/config.patch;name=tkpatch11 \
92 ${TKSRC}/locomokeyb-2.patch;name=tkpatch17 \
93 ${TKSRC}/mmc-spi.patch;name=tkpatch12 \
94 ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;name=tkpatch13 \
95 ${TKSRC}/sa1100_spinlock.patch;name=tkpatch14 \
96 ${TKSRC}/sa1100-dma.patch;name=tkpatch15 \
97 ${TKSRC}/sa1100_udc_g_ether-2.patch;name=tkpatch16 \
101 SRC_URI_append_poodle = "\
102 ${RPSRC}/poodle_serial_vcc-r0.patch;name=rppatch53 \
103 file://poodle_ts.patch \
104 file://pxafb.patch \
107 SRC_URI_append_tosa = "\
108 file://tosa/0001-Allow-runtime-registration-of-regions-of-memory-that.patch \
109 file://tosa/0002-Modify-dma_alloc_coherent-on-ARM-so-that-it-supports.patch \
110 file://tosa/0003-Core-MFD-support.patch \
111 file://tosa/0004-Add-support-for-tc6393xb-MFD-core.patch \
112 file://tosa/0005-Add-support-for-tc6387xb-MFD-core.patch \
113 file://tosa/0006-Add-support-for-t7l66xb-MFD-core.patch \
114 file://tosa/0007-Common-headers-for-TMIO-MFD-subdevices.patch \
115 file://tosa/0008-Nand-driver-for-TMIO-devices.patch \
116 file://tosa/0009-FB-driver-for-TMIO-devices.patch \
117 file://tosa/0010-OHCI-driver-for-TMIO-devices.patch \
118 file://tosa/0011-MMC-driver-for-TMIO-devices.patch \
119 file://tosa/0012-Tosa-keyboard-support.patch \
120 file://tosa/0013-USB-gadget-pxa2xx_udc-supports-inverted-vbus.patch \
121 file://tosa/0014-tosa_udc_use_gpio_vbus.patch.patch \
122 file://tosa/0015-sharpsl-export-params.patch \
123 file://tosa/0016-This-patch-fixes-the-pxa25x-clocks-definitions-to-ad.patch \
124 file://tosa/0017-Convert-pxa2xx-UDC-to-use-debugfs.patch \
125 file://tosa/0018-Fix-the-pxa2xx_udc-to-balance-calls-to-clk_enable-cl.patch \
126 file://tosa/0026-I-don-t-think-we-should-check-for-IRQs-when-determin.patch \
127 file://tosa/0027-Add-LiMn-one-of-the-most-common-for-small-non-recha.patch \
128 file://tosa/0028-Add-suspend-resume-wakeup-support-for-pda_power.patch \
129 file://tosa/0029-Support-using-VOLTAGE_-properties-for-apm-calculati.patch \
130 file://tosa/0030-Core-driver-for-WM97xx-touchscreens.patch \
131 file://tosa/0031-Add-chip-driver-for-WM9705-touchscreen.patch \
132 file://tosa/0032-Add-chip-driver-for-WM9712-touchscreen.patch \
133 file://tosa/0033-Add-chip-driver-for-WM9713-touchscreen.patch \
134 file://tosa/0034-Driver-for-WM97xx-touchscreens-in-streaming-mode-on.patch \
135 file://tosa/0035-Build-system-and-MAINTAINERS-entry-for-WM97xx-touchs.patch \
136 file://tosa/0036-Set-id-to-1-for-wm97xx-subdevices.patch \
137 file://tosa/0037-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch \
138 file://tosa/0038-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch \
139 file://tosa/0044-fix-tmio_mmc-debug-compilation.patch \
140 file://tosa/0045-Update-tmio_ohci.patch \
141 file://tosa/0046-patch-tc6393xb-cleanup.patch \
142 file://tosa/0047-tc6393xb-use-bitmasks-instead-of-bit-field-structs.patch \
143 file://tosa/0048-tc6393xb-GPIO-support.patch \
144 file://tosa/0049-platform-support-for-TMIO-on-tosa.patch \
145 file://tosa/0050-tosa-update-for-tc6393xb-gpio.patch \
146 file://tosa/0051-fix-sound-soc-pxa-tosa.c-to-new-gpio-api.patch \
147 file://tosa/0052-tosa-platform-backlight-support.patch \
148 file://tosa/0053-sound-soc-codecs-wm9712.c-28.patch \
149 file://tosa/0054-sound-soc-codecs-wm9712.c-2.patch \
150 file://tosa/0055-Add-GPIO_POWERON-to-the-list-of-devices-that-we-supp.patch \
151 file://tosa/0058-Fix-tosakbd-suspend.patch \
152 file://tosa/0059-patch-tosa-wakeup-test.patch \
153 file://tosa/0060-Add-support-for-power_supply-on-tosa.patch \
154 file://tosa/0061-tosa-bat-unify.patch \
155 file://tosa/0062-tosa-bat-fix-charging.patch \
156 file://tosa/0063-patch-tosa-bat-jacket-detect.patch \
157 file://tosa/0064-Export-modes-via-sysfs.patch \
158 file://tosa/0065-wm97xx-core-fixes.patch \
159 file://tosa/0066-tmiofb_probe-should-be-__devinit.patch \
160 file://tosa/0067-modeswitching.patch \
161 file://tosa/0068-Preliminary-tosa-denoiser.patch \
162 file://tosa/0019-pxa-remove-periodic-mode-emulation-support.patch \
163 file://tosa/0020-Provide-dew-device-clock-backports-from-2.6.24-git.patch \
164 file://tosa/0021-Add-an-empty-drivers-gpio-directory-for-gpiolib-infr.patch \
165 file://tosa/0022-Provide-new-implementation-infrastructure-that-platf.patch \
166 file://tosa/0023-This-adds-gpiolib-support-for-the-PXA-architecture.patch \
167 file://tosa/0024-Update-Documentation-gpio.txt-primarily-to-include.patch \
168 file://tosa/0025-Signed-off-by-Dmitry-Baryshkov-dbaryshkov-gmail.co.patch \
169 file://tosa/0039-Add-generic-framework-for-managing-clocks.patch \
170 file://tosa/0040-Clocklib-debugfs-support.patch \
171 file://tosa/0041-From-80a359e60c2aec59ccf4fca0a7fd20495f82b1d2-Mon-Se.patch \
172 file://tosa/0042-Use-correct-clock-for-IrDA-on-pxa.patch \
173 file://tosa/0043-Use-clocklib-for-sa1100-sub-arch.patch \
174 file://tosa/0056-Support-resetting-by-asserting-GPIO-pin.patch \
175 file://tosa/0057-Clean-up-tosa-resetting.patch \
178 SRC_URI_append_htcuniversal ="\
179 file://htcuni-acx.patch;status=external \
182 SRC_URI_append_zylonite ="\
183 file://pxa_fb_overlay.patch \
184 file://zylonite-boot.patch \
185 file://zylonite_mtd-r0.patch \
186 file://zylonite_touch-r0.patch \
187 file://zylonite_keypad-r0.patch \
190 S = "${WORKDIR}/linux-2.6.25"
192 SRC_URI[kernel.md5sum] = "db95a49a656a3247d4995a797d333153"
193 SRC_URI[kernel.sha256sum] = "108b2a3f2b05c0e57d1d0977619525e46f8d4b425aef4b38b47dcf94292f2dd2"
194 SRC_URI[rc4patch.md5sum] = "b5f96d823b1183ba0c4e61516e1a23c0"
195 SRC_URI[rc4patch.sha256sum] = "45994ebcdd4ed30b37c6fc0569ee69aee4f2ef9ed75857d0a3784ce3bfe92ffc"