help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / libsigc++-2.0 / libsigc++-2.0_2.0.6.bb
blob47fe0005b345cbf8a3b92c2ae474171ec28745bf
1 DESCRIPTION = "A library for loose coupling of C++ method calls"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 PR = "r1"
5 LICENSE = "GPL LGPL"
6 SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.0/libsigc++-${PV}.tar.gz \
7 file://define_sigc_api.patch"
8 S = "${WORKDIR}/libsigc++-${PV}"
10 inherit autotools pkgconfig
12 FILES_${PN}-dev += "${libdir}/sigc++-*/"
14 # acpaths = ""
16 do_stage() {
17 install -d ${STAGING_LIBDIR}/sigc++-2.0/include
18 install -m 0644 sigc++config.h ${STAGING_LIBDIR}/sigc++-2.0/include/
19 oe_libinstall -so -C sigc++ libsigc-2.0 ${STAGING_LIBDIR}
21 install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++
22 for f in sigc++/*.h
24 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/
25 done
26 install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
27 for f in sigc++/functors/*.h
29 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/functors
30 done
32 install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
33 for f in sigc++/adaptors/*.h
35 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors
36 done
37 install -d ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
38 for f in sigc++/adaptors/lambda/*.h
40 install -m 0644 $f ${STAGING_INCDIR}/sigc++-2.0/sigc++/adaptors/lambda
41 done
47 SRC_URI[md5sum] = "9eab84e54790093be3aa93fb4163c4b9"
48 SRC_URI[sha256sum] = "25d21557dccebbed2c7ff704fded0399194164d0a5e318791b4594a7db1cfa6b"