help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / justreader / justreader_2.0k.bb
blob9df89fa02e1c31271eb08d8a7915f0c28b0ed7cf
1 DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 HOMEPAGE = "http://justreader.sourceforge.net/"
6 PR = "r3"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
9 file://correct-settings-path.patch \
10 file://missing-include.patch"
12 S = "${WORKDIR}/TextReader2"
14 inherit palmtop
16 EXTRA_QMAKEVARS_POST += 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
17 export OE_QMAKE_LINK="${CXX}"
19 do_configure_prepend() {
20 find . -name "Makefile"|xargs rm -f
23 do_install() {
24 install -d ${D}${palmtopdir}/bin \
25 ${D}${palmtopdir}/pics/${PN}/ \
26 ${D}${palmtopdir}/apps/Applications
27 install -m 0644 apps/Applications/justreader.desktop ${D}${palmtopdir}/apps/Applications/
28 install -m 0755 bin/justreader ${D}${palmtopdir}/bin/
29 install -m 0644 pics/* ${D}${palmtopdir}/pics/justreader/
32 SRC_URI[md5sum] = "74b2b89b12668cbbbb093b6343e9f52d"
33 SRC_URI[sha256sum] = "55b0dd7ac3f9860a4cba0797213fdaa898b77f3228612e3499d54e6fe6144514"