help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / images / nas-server-image.bb
blobf26a357d95de2f57aceea7afc622759a44aef115
1 # This image is intended to provide a configuration
2 # for a network attached storage server device.
4 # Key features are:
5 #
6 # 1) Must be able to mount attached storage devices like
7 # internal disks, external USB disks, etc. Should support
8 # various filesystem choices, but ext2 at a minimum.
10 # 2) Must be able to boot from internal flash, or directly
11 # from a filesystem stored on the attached storage.
13 # 3) Must be able to share that storage across the network
14 # using various protocols like Samba, NFS, etc.
16 # 4) Bonus points for being able to support other central
17 # network services like a central gateway machine might.
19 # Although it is tested with the Angstrom distro, it is
20 # intended to be distro-agnostic.
22 DISTRO_SSH_DAEMON ?= "dropbear"
24 DEPENDS = "\
25 task-boot \
26 ${@base_contains('MACHINE_FEATURES', 'apex', 'task-base-apex', '', d)} \
27 task-distro-base task-machine-base \
28 ${DISTRO_SSH_DAEMON} \
29 ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
30 ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
31 task-nas-server-everything \
34 IMAGE_INSTALL_TASKS = "\
35 task-nas-server-everything \
38 IMAGE_INSTALL = "\
39 task-boot \
40 ${@base_contains('MACHINE_FEATURES', 'apex', 'task-base-apex', '', d)} \
41 ${DISTRO_SSH_DAEMON} \
42 ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
43 ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
44 ${IMAGE_INSTALL_TASKS} \
47 export IMAGE_BASENAME = "nas-server-image"
48 IMAGE_LINGUAS = ""
50 inherit image