help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / gnash / gnash-fb_0.8.5.bb
blob77f1b48237e98061fc99d9adba55360dc5b7b502
1 require gnash.inc
3 DEPENDS += "gst-plugins-base agg libmad"
5 acpaths = " -Imacros"
7 DEFAULT_PREFERENCE = "-1"
8 DEFAULT_PREFERENCE_angstrom = "1"
10 SRC_URI += "file://gnash-glib-dependency.patch"
12 S = "${WORKDIR}/gnash-${PV}"
14 # Boost lacks defines for lots of archs
15 TARGET_CC_ARCH_append = " -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANNESS', d, 1) == 'le']}"
18 do_configure_prepend() {
19 # fix an upstream case-typo in the configure script
20 sed -i s:Media_handler:media_handler:g ${S}/configure.ac
21 # find png not libpng
22 sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
23 for i in $(find ${S} -name "Makefile.am") ; do
24 sed -i -e s:LIBPNG:PNG:g $i
25 done
26 export CFLAGS="${CFLAGS} -lpng"
29 do_install_append() {
30 oe_runmake DESTDIR=${D} install-plugin
33 EXTRA_OECONF = "--enable-gui=fb \
34 --enable-renderer=agg \
35 --disable-klash \
36 --enable-z \
37 --enable-jpeg \
38 --disable-glext \
39 --enable-Xft \
40 --enable-expat \
41 --enable-mad \
42 --enable-cairo \
43 --enable-plugin \
44 --enable-plugins \
45 --enable-npapi \
46 --with-npapi-plugindir=${libdir}/mozilla/plugins \
47 --enable-mit-shm \
48 --disable-cygnal \
49 --with-top-level=${STAGING_DIR_HOST}/usr \
50 --without-included-ltdl \
51 --with-ltdl-include=${STAGING_INCDIR} \
52 --with-ltdl-lib=${STAGING_LIBDIR} \
53 --enable-png \
54 --with-png-incl=${STAGING_INCDIR} \
55 --with-png-lib=${STAGING_LIBDIR} \
56 --with-cairo-incl=${STAGING_DIR_HOST}/usr/include/cairo \
57 --with-cairo-lib=${STAGING_DIR_HOST}/usr/lib \
58 --enable-media=gst \
59 --with-gstreamer-incl=${STAGING_DIR_HOST}/usr/include/gstreamer-0.10 \
60 --with-gstreamer-lib=${STAGING_DIR_HOST}/usr/lib \
61 --with-glib-incl=${STAGING_DIR_HOST}/usr/include/glib-2.0 \
62 --with-glib-lib=${STAGING_DIR_HOST}/usr/lib \
63 --disable-speex \
64 --disable-speexdsp \
68 SRC_URI[md5sum] = "366f703c2eb1747e4109602b75439ff4"
69 SRC_URI[sha256sum] = "16f272214eed2ab50bcd9507d6299b82ed7d20e7e8eb253ab160e594eeb210b3"