help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / freesmartphone / pycd_git.bb
blobeebc11c0a0a77a948c7d0d9d0e3c0a84dd91831e
1 DESCRIPTION = "Python Clone Factory"
2 AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
3 SECTION = "console/network"
5 require python-helpers.inc
7 SRCREV = "${FSO_PYTHONHELPERS_SRCREV}"
8 PV = "0.1+gitr${SRCPV}"
9 PR = "r0"
11 S = "${WORKDIR}/git/${PN}"
13 RDEPENDS_${PN} = "\
14 python-dbus \
15 python-misc \
16 python-pkgutil \
17 python-resource \
20 do_compile() {
21 ${CC} pyc.c -o pyc
24 do_install() {
25 install -d ${D}${bindir}
26 install -m 755 pyc ${D}${bindir}/pyc
27 install -d ${D}${sbindir}
28 install -m 755 pycd.py ${D}${sbindir}/pycd
29 install -d ${D}${sysconfdir}/dbus-1
30 install -m 644 pycd.conf ${D}${sysconfdir}/dbus-1