help2man: fix drag in of target perl for the native package
[openembedded.git] / recipes / e17 / exalt_svn.bb
blob712204fba63de73e10d17c51b2046ee82fd9eda5
1 DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
2 HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
4 LICENSE = "LGPLv2"
5 DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
6 RDEPENDS_${PN} = "vpnc wpa-supplicant"
8 PV = "0.9+svnr${SRCPV}"
9 SRCREV = "${EFL_SRCREV}"
10 PR = "r1"
12 inherit e
13 SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
14 S = "${WORKDIR}/${SRCNAME}"
16 EXTRA_OECONF = " \
17 --with-wpa_supplicant=${sbindir}/wpa_supplicant \
18 --with-vpnc=${sbindir}/vpnc \
19 --with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
22 do_install_append() {
23 # install dbus config file
24 install -d ${D}${sysconfdir}/dbus-1/system.d/
25 install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
27 # install dbus service file
28 install -d ${D}${datadir}/dbus-1/system-services/
29 install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
32 FILES_${PN} += "${datadir}/dbus-1"