dri2proto: upgrade from 2.3 to 2.4
[openembedded.git] / recipes / supertux / supertux-qvga_0.1.3.bb
blob3be85da3989a84880c89e3e552d14f34472d2563
1 require supertux.inc
3 PR = "${INC_PR}.0"
5 DESCRIPTION += "(QVGA, size-optimized version)"
6 DEPENDS += "imagemagick-native pngcrush-native libsdl-gfx"
8 SRC_URI += " \
9 file://supertux-smallsize-data.tar.bz2 \
10 file://gp2x.patch \
11 file://img-resize.sh \
14 S = "${WORKDIR}/supertux-${PV}"
16 EXTRA_OECONF += " --enable-320x240 LIBS=-L${STAGING_LIBDIR}"
18 do_compile_prepend() {
19 for d in background shared tilesets title worldmap; do
20 cd ${S}/data/images/$d
21 sh ${WORKDIR}/img-resize.sh
22 done
25 do_install_prepend() {
26 # *-fast.* music plays when time for a level is running out
27 # byte-wise, it's the same file with few bytes changes (for .mod's).
28 # Well, seller feature, what to say, but we won't waste megabytes on
29 # that. Folks should learn to control tempo in there player lib.
30 rm -f ${S}/data/music/*-fast.*
31 # ogg is too heavy for embedded systems
32 rm -f ${S}/data/music/*.ogg
33 # cp ${WORKDIR}/*.mod ${S}/data/music/