1 DESCRIPTION
= "Python GTK+ 2.10.x Bindings"
2 SECTION
= "devel/python"
4 DEPENDS
= "gtk+ libglade python-pycairo python-pygobject"
5 RDEPENDS_$
{PN
} = "python-shell python-pycairo python-pygobject"
6 PROVIDES
= "python-pygtk2"
11 MAJ_VER
= "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
12 SRC_URI
= "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2;name=pygtk \
13 file://fix-gtkunixprint.patch \
15 S
= "${WORKDIR}/${SRCNAME}-${PV}"
19 --with-python-includes=${STAGING_INCDIR}/../ \
22 inherit autotools pkgconfig distutils
-base
24 do_configure_prepend
() {
25 install
-m
0644 $
{WORKDIR
}/acinclude.m4 $
{S
}/
27 -e s
:'`$PKG_CONFIG
--variable defsdir pygobject
-2.0`'
:\"$
{STAGING_DATADIR
}/pygobject
/2.0/defs
\":g \
28 -e s
:'`$PKG_CONFIG
--variable
=pygtkincludedir pygobject
-2.0`'
:\"$
{STAGING_INCDIR
}/pygtk
-2.0\":g \
29 -e s
:'`$PKG_CONFIG
--variable
=datadir pygobject
-2.0`'
:\"$
{STAGING_DATADIR
}\":g \
30 -e s
:'`$PKG_CONFIG
--variable codegendir pygobject
-2.0`'
:\"$
{STAGING_DATADIR
}/pygobject
/2.0/codegen
\":g \
31 -e s
:'`$PKG_CONFIG
--variable
=fixxref pygobject
-2.0`'
:\"$
{STAGING_DATADIR
}/pygobject
/xsl
/fixxref.py
\":g \
33 sed
-i 's
:tests docs
:tests
:' Makefile.am
36 # dirty fix #
1: remove dependency on python
-pygobject
-dev
38 find $
{D
} -name
"*.la"|xargs rm
-f
39 rm
-f $
{D
}/$
{bindir
}/pygtk
-codegen
-2.0
40 rm
-rf $
{D
}/$
{libdir
}/pkgconfig
41 install
-d $
{D
}$
{libdir
}/pkgconfig
42 install
-m
0644 $
{S
}/*.pc $
{D
}$
{libdir
}/pkgconfig
45 # dirty fix #
2: fix build system paths leaking in
48 PACKAGES
=+ "${PN}-demo"
50 ${bindir}/pygtk-demo \
53 RDEPENDS_$
{PN
}-demo
= "python-pygtk python-stringold python-lang"
55 # todo
: revamp packaging
, package demo seperatly
62 SRC_URI
[pygtk.md5sum
] = "bd0d437fefd6d5390f5d770a495cd50c"
63 SRC_URI
[pygtk.sha256sum
] = "7fae5e01af217a01738eae41c38ad7f86d1f538f444300d0fa2847aafb7444a8"