am-benchmarks: Add support for am387x-evm machine
[openembedded.git] / recipes / python / python-dbus_0.83.2.bb
blob7c6eebb4a13c63d58c6bb346ec3424d340c13713
1 DESCRIPTION = "Python bindings for DBus, a socket-based message bus system for interprocess communication"
2 SECTION = "devel/python"
3 HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4 LICENSE = "MIT"
5 DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native python-epydoc-native"
6 PR = "ml0"
8 SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
9 S = "${WORKDIR}/dbus-python-${PV}"
11 inherit distutils-base autotools pkgconfig
13 export BUILD_SYS
14 export HOST_SYS
16 RDEPENDS_${PN} = "\
17 python-io \
18 python-lang \
19 python-logging \
20 python-threading \
21 python-xml \
24 FILES_${PN}-dev += "\
25 ${libdir}/pkgconfig \
28 do_configure_append() {
29 find ${S} -name Makefile | xargs -n 1 sed -i 's,prefix}lib,prefix}/lib,g'
32 SRC_URI[md5sum] = "4ebcaa905bdcb4132b915196b0a3691b"
33 SRC_URI[sha256sum] = "883729c98f40790021e3be0f7028ae863ee1c4a7b922a5578c1342592adfff64"