am-benchmarks: Add support for am387x-evm machine
[openembedded.git] / recipes / cherokee / cherokee_0.4.29.bb
blobadbdc3f4351d664041f1adb12da84471b4297062
1 # Cherokee web server
2 DESCRIPTION = "Cherokee Web Server fast and secure"
3 LICENSE = "GPL"
4 SECTION = "network"
5 DEPENDS = "openssl libpcre"
6 SRC_URI = "http://www.0x50.org/download/0.4/${PV}/${P}.tar.gz \
7 file://configure.patch \
8 file://Makefile.in.patch \
9 file://Makefile.cget.patch \
10 file://util.patch"
11 INC_PR = "r7"
12 PR = "${INC_PR}.0"
14 inherit autotools
16 LEAD_SONAME = "libcherokee-base"
18 EXTRA_OECONF = "--enable-tls=openssl --disable-static --disable-nls"
20 do_configure() {
21 gnu-configize
22 oe_runconf
25 do_install_prepend () {
26 ${BUILD_CC} ${BUILD_CFLAGS} -DHAVE_SYS_STAT_H -o cherokee_replace cherokee_replace.c
29 SRC_URI[md5sum] = "854e6e61a69781746496012658d8ef98"
30 SRC_URI[sha256sum] = "7091536ef2a51d2548ac6268cc846dda9c37f7f7348597868c793f42b9be7d78"